Inkscape tutorial: Trucchi

Questo tutorial mostra vari trucchi che gli utenti più esperti utilizzano in Inkscape e delle funzionalità “nascosta” che possono essere utili per aumentare la propria produttività.

Radial placement with Tiled Clones

It's easy to see how to use the Create Tiled Clones dialog for rectangular grids and patterns. But what if you need radial placement, where objects share a common center of rotation? It's possible too!

If your radial pattern only needs to have 3, 4, 6, 8, or 12 elements, then you can try the P3, P31M, P3M1, P4, P4M, P6, or P6M symmetries. These will work nicely for snowflakes and the like. A more general method, however, is as follows.

Choose the P1 symmetry (simple translation) and then compensate for that translation by going to the Shift tab and setting Per row/Shift Y and Per column/Shift X both to -100%. Now all clones will be stacked exactly on top of the original. All that remains to do is to go to the Rotation tab and set some rotation angle per column, then create the pattern with one row and multiple columns. For example, here's a pattern made out of a horizontal line, with 30 columns, each column rotated 6 degrees:

An example image

To get a clock dial out of this, all you need to do is cut out or simply overlay the central part by a white circle (to do boolean operations on clones, unlink them first).

More interesting effects can be created by using both rows and columns. Here's a pattern with 10 columns and 8 rows, with rotation of 2 degrees per row and 18 degrees per column. Each group of lines here is a “column”, so the groups are 18 degrees from each other; within each column, individual lines are 2 degrees apart:

An example image

In the above examples, the line was rotated around its center. But what if you want the center to be outside of your shape? Just click on the object twice with the Selector tool to enter rotation mode. Now move the object's rotation center (represented by a small cross-shaped handle) to the point you would like to be the center of the rotation for the Tiled Clones operation. Then use Create Tiled Clones on the object. This is how you can do nice “explosions” or “starbursts” by randomizing scale, rotation, and possibly opacity:

An example image

How to do slicing (multiple rectangular export areas)?

Create a new layer, in that layer create invisible rectangles covering parts of your image. Make sure your document uses the px unit (default), turn on grid and snap the rects to the grid so that each one spans a whole number of px units. Assign meaningful ids to the rects, and export each one to its own file (File > Export PNG Image (Shift+Ctrl+E)). Then the rects will remember their export filenames. After that, it's very easy to re-export some of the rects: switch to the export layer, use Tab to select the one you need (or use Find by id), and click Export in the dialog. Or, you can write a shell script or batch file to export all of your areas, with a command like:

inkscape -i area-id -t nomefile.svg

for each exported area. The -t switch tells it to use the remembered filename hint, otherwise you can provide the export filename with the -e switch. Alternatively, you can use the Extensions > Web > Slicer extensions, or Extensions > Export > Guillotine for similar results.

Gradienti non-lineari

The version 1.1 of SVG does not support non-linear gradients (i.e. those which have a non-linear translations between colors). You can, however, emulate them by multistop gradients.

Start with a simple two-stop gradient (you can assign that in the Fill and Stroke dialog or use the gradient tool). Now, with the gradient tool, add a new gradient stop in the middle; either by double-clicking on the gradient line, or by selecting the square-shaped gradient stop and clicking on the button Insert new stop in the gradient tool's tool bar at the top. Drag the new stop a bit. Then add more stops before and after the middle stop and drag them too, so that the gradient looks smooth. The more stops you add, the smoother you can make the resulting gradient. Here's the initial black-white gradient with two stops:

An example image

And here are various “non-linear” multi-stop gradients (examine them in the Gradient Editor):

An example image

Gradienti radiali eccentrici

Radial gradients don't have to be symmetric. In Gradient tool, drag the central handle of an elliptic gradient with Shift. This will move the x-shaped focus handle of the gradient away from its center. When you don't need it, you can snap the focus back by dragging it close to the center.

An example image

Allineamento al centro della pagina

To align something to the center or side of a page, select the object or group and then choose Page from the Relative to: list in the Align and Distribute dialog (Shift+Ctrl+A).

Pulizia del documento

Many of the no-longer-used gradients, patterns, and markers (more precisely, those which you edited manually) remain in the corresponding palettes and can be reused for new objects. However if you want to optimize your document, use the Clean up Document command in File menu. It will remove any gradients, patterns, or markers which are not used by anything in the document, making the file smaller.

Proprietà nascoste e l'editor XML

L'editor XML (Maiusc+Ctrl+X) permette di cambiare quasi tutti gli aspetti del documento senza usare un editor esterno. Inoltre, Inkscape supporta più funzionalità SVG di quante siano accessibili dall'interfaccia grafica. L'editor XML è un modo per avere accesso a queste funzionalità (conoscendo il formato SVG).

Cambiare le unità di misura del righello

In the default template, the unit of measure used by the rulers is mm. This is also the unit used in displaying coordinates at the lower-left corner and preselected in all units menus. (You can always hover your mouse over a ruler to see the tooltip with the units it uses.) To change this, open Document Properties (Shift+Ctrl+D) and change the Display units on the Page tab.

Duplicazione veloce

Per creare rapidamente molte copie di un oggetto, si può selezionarlo e, tenendo premuto il pulsante del mouse, premere Spazio. Lascerà una sorta di timbro della forma dove e per quante volte desiderato.

Pen tool tricks

Con lo strumento Penna, si può terminare il disegno di una linea:

Nota che quando il tracciato non è finito (ovvero è verde, con l'ultimo segmento in rosso), questo non esiste ancora come oggetto nel documento. Quindi, per cancellarlo, premere Esc (cancella l'intero tracciato) o Backspace (rimuove l'ultimo segmento del tracciato non concluso) invece di Annulla.

Per aggiungere un nuovo sottotracciato ad un tracciato esistente, selezionare il tracciato e iniziare a disegnare premendo Maiusc da un punto arbitrario. Se si vuole semplicemente continuare un tracciato esistente, non è necessario premere Maiusc, ma solo iniziare il disegno da uno dei due punti di ancoraggio del tracciato selezionato.

Inserire valori Unicode

Con lo strumento Testo, premendo Ctrl+U si commuta tra modalità Unicode e normale. In modalità Unicode, ogni gruppo di 4 caratteri esadecimali digitati divengono un singolo carattere Unicode, permettendo di inserire simboli arbitrari (se si conosce il loro corrispondente Unicode e se il tipo di carattere li supporta). Per uscire dalla modalità Unicode premere Invio. Per esempio, Ctrl+U 2 0 1 4 Invio inserisce un trattino (—). Per uscire dalla modalità Unicode senza inserire nulla premere Esc.

You can also use the Text > Glyphs dialog to search for and insert glyphs into your document.

Uso della griglia per disegnare icone

Nel caso si voglia creare un'icona 24x24: creare una pagina di dimensioni 24x24 px (usare Proprietà Documento) e impostare la griglia a 0.5 px (griglia 48x48). Ora, se si allineano oggetti con riempimento alle linee della griglia pari, e oggetti con contorno a quelle dispari (con un contorno di spessore un numero di px pari) e lo si esporta con una risoluzione di 96dpi (cosi che 1 px diventi 1 pixel bitmap), si ottiene un'immagine bitmap precisa senza necessità di anti-aliasing.

Rotazione di oggetti

Con lo strumento Selezione, Cliccando due volte su un oggetto per mostrare le frecce di rotazione e distorsione. Se le frecce agli angoli vengono cliccate e spostate, l'oggetto ruoterà attorno al centro (mostrato con un segno a croce). Premendo contemporaneamente Maiusc, la rotazione avverrà attorno all'angolo opposto. Si può spostare il punto di rotazione in qualsiasi posizione.

Oppure, si può ruotare con la tastiera premendo [ e ] (di 15 gradi) o Ctrl+[ e Ctrl+] (di 90 gradi). Sempre con [] ma premendo il tasto Alt ruoterà di un pixel.

Ombre

Per creare rapidamente ombre di oggetti, usare Filtri > Ombre e aloni > Proietta ombra....

You can also easily create blurred drop shadows for objects manually with blur in the Fill and Stroke dialog. Select an object, duplicate it by Ctrl+D, press PgDown to put it beneath original object, place it a little to the right and lower than original object. Now open Fill And Stroke dialog and change Blur value to, say, 5.0. That's it!

Posizionare un testo su un tracciato

Per posizionare un testo su un tracciato, selezionare il testo e il tracciato insieme e usare Metti su tracciato dal menù Testo. Il testo comincerà all'inizio del tracciato. In generale, è preferibile creare un tracciato apposito che sia adatto al testo piuttosto che adattare del testo ad un disegno esistente - questo darà maggior controllo senza distorcere il disegno.

Selezionare l'originale

Quando si ha un testo su un tracciato, una proiezione collegata, o un clone, il loro oggetto/tracciato sorgente può essere difficile da selezionare perchè è esattamente sottostante o reso invisibile e/o bloccato. La combinazione Maiusc+D ti aiuterà. Selezionando il testo, la proiezione collegata, o il clone e premendo Maiusc+D muoverà la selezione verso il corrispondente tracciato, la sorgente della proiezione o il clone originale.

Recupero di finestre fuori dallo schermo

Quando si spostano documenti tra sistemi con differenti risoluzioni o numero di schermi, può capitare che Inkscape salvi la posizione di una finestra che la colloca fuori dallo schermo. Massimizza semplicemente la finestra (che tornerà ad essere visibile, usa la barra delle applicazioni), salva e ricarica. Si può evitare direttamente il problema deselezionando l'opzione globale per il salvataggio della geometria della finestra (Preferenze, Interfaccia > Finestre).

Trasparenze, gradienti e esportare PostScript

PostScript or EPS formats do not support transparency, so you should never use it if you are going to export to PS/EPS. In the case of flat transparency which overlays flat color, it's easy to fix it: Select one of the transparent objects; switch to the Dropper tool (F7 or d); make sure that the Opacity: Pick button in the dropper tool's tool bar is deactivated; click on that same object. That will pick the visible color and assign it back to the object, but this time without transparency. Repeat for all transparent objects. If your transparent object overlays several flat color areas, you will need to break it correspondingly into pieces and apply this procedure to each piece. Note that the dropper tool does not change the opacity value of the object, but only the alpha value of its fill or stroke color, so make sure that every object's opacity value is set to 100% before you start out.