Inkscape tutorial: Trucs et astuces

Ce didacticiel présente divers trucs et astuces trouvés par des utilisateurs au cours de leur utilisation d'Inkscape, ainsi que quelques fonctionnalités cachées qui peuvent vous aider à accélérer votre production.

Disposition radiale avec un pavage de clones

Il est facile de comprendre comment se servir de la boîte de dialogue Créer un pavage de clones pour créer des motifs ou des grilles rectangulaires. Mais comment créer une disposition radiale, où les objets partagent un même centre de rotation ? C'est possible aussi !

Si votre motif radial ne doit comporter que 3, 4, 6, 8 ou 12 éléments, vous pouvez alors essayer les symétries P3, P31M, P3M1, P4, P4M, P6 ou P6M. Celles-ci fonctionnent bien pour obtenir des flocons ou des formes similaires. Voici toutefois une méthode plus générale.

Choisissez la symétrie P1 (translation simple) puis compensez cette translation en allant dans l'onglet Translation et en définissant Par ligne/Translation Y et Par colonne/Translation X à -100 %. Les clones seront alors empilés juste au-dessus de l'original. Tout ce qu'il reste à faire est d'aller dans l'onglet Rotation et de définir un angle par colonne, puis de créer le motif avec une ligne et plusieurs colonnes. Par exemple, voici un motif fait d'une ligne horizontale et de 30 colonnes, chacune de ces colonnes étant tournée de 6 degrés :

An example image

Pour en faire un cadran, il suffit de découper ce motif ou recouvrir sa partie par un disque blanc (pour effectuer des opérations booléennes sur des clones, déliez-les d'abord).

Des effets plus intéressants peuvent être créés en utilisant à la fois les lignes et les colonnes. Voici un motif de 10 colonnes et 8 lignes, avec une rotation de 2 degrés par lignes et 18 par colonne. Chaque groupe de segments ici est « une colonne », donc les groupes sont séparés entre eux de 18 degrés ; en sein de chaque « colonne », les segments sont séparés de 2 degrés :

An example image

Dans les exemples ci-dessus, le segment a été tourné autour de son centre. Mais comment faire si vous voulez que le centre soit en dehors de votre forme ? Cliquez deux fois sur l'objet avec l'outil Sélecteur pour entrer en mode rotation, puis déplacez le centre de rotation de l'objet (représenté par une petite poignée en forme de croix) vers le centre de rotation souhaité pour le pavage. Utilisez ensuite Créer un pavage de clones sur l'objet. C'est ainsi que vous pouvez créer de belles explosions et éclaboussures avec une échelle, une rotation et éventuellement une opacité aléatoires :

An example image

Exporter des zones rectangulaires multiples

Créez un nouveau calque, et dans ce calque, créez des rectangles invisibles recouvrant des parties de votre image. Assurez-vous que votre document adopte le px comme unité (cas par défaut), affichez la grille et faites coller les rectangles à cette grille de sorte que chacun d'entre eux aient des coordonnées en px entières. Donnez des identifiants significatifs aux rectangles, et exportez chacun d'entre eux dans un fichier différent (Fichier > Exporter une image PNGMaj+Ctrl+E). Chacun des rectangles se « souviendra » ainsi de son nom de fichier d'export. Après cela, il est facile de réexporter certains de ces rectangles : passez dans le calque d'export, utilisez Tab pour sélectionner celui dont vous avez besoin (ou faites une Recherche par identifiant), et enfin cliquez sur Exporter dans la boîte de dialogue. Vous pouvez aussi écrire un script shell ou un fichier batch pour exporter ces zones avec une commande telle que :

inkscape -i area-id -t nomdefichier.svg

pour chaque zone. L'option -t indique à Inkscape d'utiliser le nom de fichier enregistré avec la zone ; vous pouvez aussi fournir un autre nom pour l'export avec l'option -e. Une autre possibilité est d'utiliser les extensions Extensions > Web > Découpe, ou Extensions > Exporter > Guillotine qui permettent d'automatiser l'export depuis des documents SVG Inkscape, en utilisant au choix des guides ou un calque de découpage.

Dégradés non linéaires

La version 1.1 du SVG ne supporte pas les dégradés non linéaires (c'est-à-dire ayant des transitions non linéaires entre les couleurs). Vous pouvez cependant les émuler grâce à des dégradés multi-stops.

Commencez par créer un dégradé avec deux stops (vous pouvez le définir dans la boîte de dialogue Fond et contour ou utiliser l'outil Dégradé). À présent, avec l'outil Dégradé, ajoutez un nouveau stop au milieu du dégradé, soit en double-cliquant sur la ligne du dégradé, soit en sélectionnant le stop de forme carrée et en cliquant sur le bouton Insérer un nouveau stop dans la barre de contrôle de l'outil Dégradé ; puis déplacez légèrement ce nouveau stop. Ensuite, ajoutez d'autres stops de part et d'autre de celui du milieu et déplacez-les aussi de sorte que le dégradé ait l'air lisse. Plus vous ajoutez de stops, plus vous pouvez rendre le dégradé résultant soyeux. Voici le dégradé initial avec deux stops (noir et blanc) :

An example image

Et voici quelques dégradés multi-stops non-linéaires (examinez-les dans l'éditeur de dégradés) :

An example image

Dégradés radiaux excentriques

Les dégradés radiaux ne sont pas nécessairement symétriques. Dans l'outil Dégradé, déplacez la poignée centrale d'un dégradé elliptique tout en appuyant sur Maj. Cela vous permettra de déplacer la poignée du foyer (en forme de « X ») du dégradé en la séparant du centre. Si vous n'en avez plus besoin, vous pouvez replacer la poignée de foyer au centre.

An example image

Alignement au centre de la page

Pour aligner quelque chose au centre ou le long d'un côté de la page, sélectionnez l'objet ou le groupe à aligner puis ouvrez la boîte de dialogue Aligner et distribuer (Maj+Ctrl+A). Vous pouvez alors choisir la Page dans la liste relativement à et enfin aligner votre sélection comme vous le désirez.

Nettoyage du document

Quand ils ne sont plus utilisés, beaucoup de dégradés, motifs et marqueurs (plus précisément, ceux que vous avez édités manuellement) restent dans les palettes correspondantes et peuvent être utilisés dans de nouveaux objets. Cependant, si vous voulez optimiser votre document, utilisez la commande Nettoyer le document du menu Fichier. Elle supprimera tout dégradé, motif ou marqueur qui n'est plus utilisé par aucun objet du document, réduisant ainsi la taille du fichier.

Fonctionnalités cachées et éditeur XML

L'éditeur XML (Maj+Ctrl+X) vous permet de modifier la plupart des aspects du document sans avoir à utiliser un éditeur de texte externe. De plus, Inkscape supporte souvent des fonctionnalités SVG pas encore accessibles depuis l'interface graphique. L'éditeur XML offre la possibilité d'accéder à ces fonctionnalités (à condition de connaître le SVG).

Changer l'unité de mesure des règles

Dans le modèle par défaut, l'unité de mesure utilisée par les règles est le millimètre (mm). C'est aussi l'unité utilisée pour afficher les coordonnées dans le coin inférieur gauche, et celle présélectionnée dans les menus qui font intervenir des unités (vous pouvez placer votre souris sur une règle pour faire apparaître une bulle indiquant l'unité utilisée). Pour modifier cela, ouvrez les Propriétés du document (Maj+Ctrl+D) et changez l'Unité par défaut dans l'onglet Page.

Appliquer des coups de tampon

Pour créer rapidement plusieurs copies d'un objet, utilisez le coup de tampon. Déplacez simplement un objet (ou redimensionnez/tournez-le) et, alors que le bouton de la souris est toujours pressé, appuyez sur Espace. Ceci appose un « tampon » de l'objet courant. Vous pouvez répéter ce coup de tampon autant de fois que vous le voulez.

Astuces du stylo

Avec l'outil Stylo (courbes de Bézier), vous pouvez achever votre ligne de plusieurs façons :

Notez que tant que le chemin n'est pas terminé (c'est-à-dire qu'il est affiché en vert, avec le segment actuel en rouge), il n'existe pas encore en tant qu'objet dans le document. Pour l'annuler, vous pouvez donc utiliser les raccourcis Échap (abandonner complètement le chemin) ou Retour arrière (supprimer le dernier segment du chemin non terminé) à la place d'Annuler.

Pour ajouter un nouveau sous-chemin à un chemin existant, sélectionnez ce chemin et commencez à dessiner (d'où vous voulez) tout en appuyant sur Maj. Cependant, si vous voulez simplement prolonger un chemin existant, Maj n'est pas nécessaire ; commencez simplement à dessiner depuis l'une des ancres situées aux extrémités du chemin sélectionné.

Entrer des valeurs Unicode

Quand vous êtes dans l'outil Texte, appuyer sur Ctrl+U permet d'alterner les modes Normal et Unicode. En mode Unicode, chaque groupe de 4 chiffres hexadécimaux que vous tapez devient un caractère Unicode, vous permettant ainsi de taper les symboles que vous voulez (si vous connaissez leur numéro Unicode, et si la police les supporte). Pour valider un caractère Unicode, appuyez sur Entrée. Par exemple, Ctrl+U 2 0 1 4 Entrée insère un tiret long (—). Pour quitter le mode Unicode sans insérer quoi que ce soit, appuyez sur la touche Échap.

Vous pouvez également utiliser la boîte de dialogue Texte > Glyphes pour rechercher et insérer des glyphes dans votre document.

Utilisation de la grille pour dessiner des icônes

Supposons que vous vouliez créer une icône de 24×24 pixels. Créez un canevas de 24×24 px (utilisez les Préférences du document) et créez une grille avec un espacement de 0,5 px (48×48 lignes de grille, donc). Maintenant, si vous alignez des objets avec un fond sur les lignes paires de la grille et les contours sur les lignes impaires, avec un nombre pair (en px) comme largeur de contour, en exportant le document à la résolution par défaut de 96 ppp (de sorte qu'1 px corresponde à 1 pixel en matriciel), vous obtiendrez une icône matricielle nette ne nécessitant pas d'anticrénelage.

Rotation d'objets

Avec l'outil Sélecteur, le clic sur un objet permet d'afficher les flèches de redimensionnement, et un clic de plus sur l'objet permet d'afficher les flèches d'inclinaison et de rotation. Si vous déplacez les flèches des coins, l'objet tournera autour du centre (représenté par une croix). Si vous appuyez sur Maj pendant cette opération, la rotation se fera autour du coin opposé. Vous pouvez aussi déplacer le centre de rotation (la croix) où vous le désirez.

Ou bien, vous pouvez effectuer une rotation en utilisant les raccourcis clavier : [ et ] (de 15 degrés) ou Ctrl+[ et Ctrl+] (de 90 degrés). Ces mêmes raccourcis [] combinés avec Alt permettent des rotations lentes à l'échelle du pixel.

Ombres portées

Pour créer rapidement une ombre portée sur des objets, utilisez la fonctionnalité Filtres > Ombres et lueurs > Ombre portée….

Vous pouvez aussi facilement créer des ombres portées manuellement avec le paramètre de flou de la boîte de dialogue Fond et contour. Sélectionnez un objet, dupliquez-le avec Ctrl+D, appuyez sur la touche Page suivante pour déplacer le duplicata sous l'objet original, puis déplacez-le légèrement vers le bas et la droite par rapport à l'original. Ouvrez maintenant la boîte de dialogue Fond et contour et changez la valeur du flou à 5. Le tour est joué !

Placement d'un texte le long d'un chemin

Pour placer du texte le long d'une courbe, sélectionnez le texte et la courbe puis utilisez la commande Mettre suivant un chemin du menu Texte. Le texte commencera au début du chemin. En général, il vaut mieux créer un chemin auquel vous voulez que le texte s'adapte plutôt que d'adapter ce texte à un autre élément (préexistant) du dessin — cela vous autorisera un meilleur contrôle sans avoir à « bricoler » votre dessin.

Sélection de l'original

Quand vous avez affaire à un texte suivant un chemin, un décalage lié ou un clone, son objet/chemin source peut être difficile à sélectionner (caché sous d'autres objets, rendu invisible et/ou verrouillé). Le raccourci magique Maj+D peut alors vous aider : sélectionnez le texte, le décalage lié ou le clone et appuyez sur Maj+D pour sélectionner alors le chemin correspondant, la source du décalage ou du clone.

Au cas où la fenêtre serait hors de l'écran

Quand vous transférez des documents entre des systèmes avec des résolutions ou un nombre d'écrans différents, vous pouvez être confronté au problème suivant : Inkscape a enregistré une position de fenêtre qui fait que vous ne pouvez plus atteindre Inkscape sur votre écran. Il suffit de maximiser la fenêtre (ce qui devrait la rendre de nouveau visible à l'écran ; utilisez la barre des tâches), d'enregistrer le document et de le recharger. Vous pouvez éviter tout cela en désactivant l'option « enregistrer la taille et la position des fenêtres » (dans l'onglet Interface > Fenêtres des Préférences d'Inkscape).

Transparence, dégradés et export en Postscript

Les formats PostScript et EPS ne supportent pas la transparence, aussi vous ne devriez pas en utiliser si vous comptez exporter en PS/EPS. Dans le cas d'une transparence uniforme couvrant une couleur uniforme, il est facile d'y remédier : sélectionnez l'un des objets transparents, prenez l'outil Pipette (F7), assurez-vous que le bouton Opacité : Capturer est désactivé dans la barre de contrôle de la Pipette et cliquez sur ce même objet. La couleur visible sera capturée et réassignée à l'objet mais cette fois, sans transparence. Répétez cette opération pour tous les objets transparents. Si votre objet transparent chevauche plusieurs zones de différentes couleurs uniformes, vous devrez le découper en morceaux (un morceau par zone) puis appliquer cette procédure à chacun des morceaux. Notez que l'outil Pipette ne change pas la valeur d'opacité de l'objet, mais seulement la valeur alpha de sa couleur de fond ou de contour ; assurez-vous donc que tous les objets ont une opacité de 100 % avant de commencer.