Inkscape tutorial: 基本

このチュートリアルは Inkscape の基本的な使用法について説明しています。これは Inkscape 正規のドキュメントであり閲覧、編集、複製、および保存が可能です。

この基本チュートリアルは、キャンバスの操作、ドキュメントの取り扱い、シェイプツールの基本、選択方法、選択ツールを用いたオブジェクトの変形、グループ化、フィルとストロークの設定、配置、Z 軸順序について記述しています。さら進んだトピックについてはヘルプメニューのその他のチュートリアルをご覧ください。

キャンバスのパン

ドキュメントを表示しているキャンバスをパン (スクロール) する方法はいくつかあります。Ctrl+矢印キーでキーボードからスクロールを行うことができます (このドキュメントを下にスクロールしてみてください)。他に、マウスの中央ボタンでキャンバスをドラッグ、およびスクロールバー (Ctrl+B で表示、非表示できます) を使うことでも行えます。マウスの ホイール を使って垂直方向のスクロール、Shift キーを押しながらマウスホイールを使うと水平方向にスクロールします。

ズームインとズームアウト

ズームを行う最も簡単な方法は -+ (または = ) キーを押すことです。Ctrl+中央クリックCtrl+右クリック でズームイン、Shift+中央クリックShift+右クリック でズームアウトし、Ctrl を押しながらマウスホイールを使うこともできます。また、ズーム入力域 (ドキュメントウインドウの右下隅) をクリックし、正確なズーム値を % で入力して Enter キーを押すこともでも行えます。ドラッグした領域をズームすることのできるズームツール (左のツールバーにあります) もあります。

Inkscape はセッションでのズームレベルの履歴を保持しています。` キーを押すと前のズーム状態に戻り、Shift+` キーで次に進みます。

Inkscape のツール

左側の縦のツールバーには Inkscape の描画ならびに編集ツールを表示しています。ウインドウの一番上、メニューの下に一般的なコマンドボタンのあるコマンドバー、そして各ツール固有のの入力域を表示するツールコントロールバーが配置されています。ウインドウの下にあるステータスバーには作業に応じて有用なヒントとメッセージが表示されます。

多くの操作がキーボードショートカットから利用できます。ヘルプ > キーとマウスのリファレンス を開いて完全なリファレンスを確認できます。

ドキュメントの作成と管理

To create a new empty document, use File > New > Default or press Ctrl+N. To create a new document from one of Inkscape's many templates, use File > New > Templates... or press Ctrl+Alt+N

To open an existing SVG document, use File > Open (Ctrl+O). To save, use File > Save (Ctrl+S), or Save As (Shift+Ctrl+S) to save under a new name. (Inkscape may still be unstable, so remember to save often!)

Inkscape はファイル形式に SVG (Scalable Vector Graphics) を採用しています。SVG は広くグラフィックソフトウェアで使用されているオープンな標準です。SVG ファイルは、XML を基準としていてあらゆるテキストエディターと XML エディターで編集することができます (そう、Inkscape をはなれても)。Inkscape は SVG 以外のフォーマット (EPS や PNG など) の入出力も行えます。

Inkscape はドキュメントごとに個別のウインドウを開きます。複数のドキュメントはウインドウマネージャーを使い (例えば Alt+Tab を使って) 操作することができ、また Inkscape のショートカット、Ctrl+Tab ですべての開いているドキュメントウィンドウを巡回できます (練習のためドキュメントを新規作成し、このドキュメントと切り替えてみましょう)。注意: Inkscape はこれらのウインドウをウェブブラウザーのタブのように扱います。これはすなわち、ショートカット Ctrl+Tab は同じプロセス上で動作しているドキュメントに対してのみ機能することを意味します。ファイルブラウザーから複数のファイルを開いたり、Inkscape をメニューやアイコンから複数起動したときにはそれぞれの間で切り替えは行われません。

シェイプの作成

格好いいシェイプを作ってみよう! ツールバーの矩形ツールをクリック (か F4 を押す) し、新しいドキュメントの中か、ここでクリックおよびドラッグしてみましょう:

An example image

見ての通り、デフォルトの矩形は青く半透明で、黒いストローク (輪郭) になっています。これがどう変わるかを見ていきましょう。他のツール、円/弧、星形、螺旋を作ってみましょう。

An example image

これらのツールは総称してシェイプツールと呼ばれます。各シェイプには一つ以上のひし形のハンドルがあります。このハンドルをドラッグしてシェイプがどう変わるか見てみましょう。シェイプのコントロールパネルはシェイプを調整するもう一つの方法です。コントロールは選択中のシェイプ (すなわち、ハンドルの表示されているシェイプ) に効果があり、そして新しく作成したシェイプのデフォルト値として適用されます。

最後に行った操作を元に戻すには、 Ctrl+Z を押します (そして、もしまた気が変ったなら、元に戻した操作を Shift+Ctrl+Z を押すことでやり直しすることができます)。

移動、拡大縮小、回転

Inkscape で最もよく使われるツールは選択ツールです。ツールバーの一番上にあるボタン (矢印の) をクリックするか、または F1Space を押します。するとキャンバス上のすべてのオブジェクトが選択可能になります。この矩形をクリックしてみましょう。

An example image

矢印型の 8 個のハンドルがオブジェクトの回りに表示されます。ここで:

今一度矩形をクリックしてください。ハンドルが変るはずです。ここで:

選択ツールの状態で、(キャンバスの上にある) コントロールバーの数値入力フィールドを使用し、正確な座標 (X とY) と大きさ (幅と高さ) を入力することもできます。

キーによる変形

他のベクターエディターに比べ Inkscape を大きく特徴づけているのは、キーボード操作の重視です。キーボードから操作できないコマンドや操作はほとんどなく、オブジェクトの変形も例外ではありません。

キーボードからオブジェクトの移動 (矢印キー)、拡大縮小 (< > キー)、そして回転 ([] キー) が可能です。デフォルトの移動および拡大縮小は 2px ごとになります。Shift を押すと 10 倍で移動します。Ctrl+>Ctrl+< でそれぞれ元の 200%、50% で拡大縮小します。デフォルトの回転は 15 度ごとになります。Ctrl を使うと 90 度ごとに回転します。

しかし、もっとも有用なのは Alt キーと変形キーを用いて行うピクセル単位の変形でしょう。例えば、Alt+矢印 は、選択したオブジェクトを、そのときのズーム状態で 1 ピクセル移動します (すなわち、1 スクリーンピクセルであり、ズーム状態と関係ない SVG の長さの単位 px と混乱しないように)。つまり、もしズームインした状態で Alt+矢印 を実行すると、画面上では 1 ピクセル動きますが、実際のドキュメント上での絶対値ではより小さい移動になります。従って、ズームイン、ズームアウトを行うことで任意の精度でオブジェクトの位置決めを行うことができます。

同様に、Alt+>Alt+< で、選択したオブジェクトの見た目の大きさをスクリーンピクセルで拡大縮小できます。また Alt+[Alt+] でオブジェクトの中心点から最も遠い点が、1 スクリーンピクセル移動する分だけ回転します。

注意: Linux の場合は Altキーと他のいくつかのキーの組み合わせで期待した動作が行われないかもしれません。これはウィンドウマネージャーがそれらキー入力を受け付け、Inkscape に渡されないために発生します。一つの解決策として、ウィンドウマネージャーのキー設定を適宜変更することが挙げられます。

複数選択

Shift+クリック でオブジェクトをいくつでも同時に選択することができます。また、オブジェクトの周りを ドラッグ することでも選択することが可能です。これはラバーバンド選択と呼ばれています (選択ツールは何もないところからドラッグを始めるとラバーバンドを作り、ドラッグを始める前に Shift を押すと常にラバーバンドが作られます)。下の 3 つのシェイプで練習しましょう:

An example image

それでは、ラバーバンドを使って (ドラッグか Shift+ドラッグ で) 矩形以外の 2 つの楕円を選択してみましょう:

An example image

選択されている各オブジェクトは、デフォルトで破線の矩形である選択キューを表示します。このキューは何が選択されていて何が選択されていないのかを一度に確認するのに役立ちます。例えば、もし 2 つの楕円と矩形を選択した場合、選択キューがないと楕円が選択されているかどうかを判断するのが難しいでしょう。

選択したオブジェクトに対して Shift+クリック を行うとそのオブジェクトは選択から除外されます。上の 3 つのオブジェクトを選択して、Shift+クリック を 2 つの楕円に対して行うと、選択の中には一つの矩形だけが残されます。

Esc を押すことですべてのオブジェクトの選択を解除します。 Ctrl+A で現在のレイヤーにあるすべてのオブジェクトを選択します (もしレイヤーを作成していない場合これはドキュメントのすべてのオブジェクトを選択するのと同じです)。

グループ化

複数のオブジェクトを結合してグループにすることができます。グループはドラッグや変形をすると一つのオブジェクトのように振る舞います。下の左の 3 つのオブジェクトは別個のもので、右の 3 つのオブジェクトはグループです。グループをドラッグしてください。

An example image

グループを作るには、1 つ以上のオブジェクトを選択して Ctrl+G を押します。グループを解除するには、選択してから Ctrl+U を押します。グループ自体も他のオブジェクトと同じようにグループ化されます。このような再帰的グループ化は任意の深さにできますが、Ctrl+U は選択の最上位のグループのみをグループ解除します。深くグループ化したグループを完全に解除するには何度も Ctrl+U を押す必要があります。

しかし、もしグループ化されたオブジェクトの中の 1 つを編集したいのなら、グループを解除する必要はありません。Ctrl+クリック するだけでオブジェクトを単独で選択、編集でき、Shift+Ctrl+クリック で複数のオブジェクト (グループ内であれ外であれ) をグループ化を気にせず選択できます。グループ中の個々のオブジェクト (上図右) をグループ解除せずに移動や変形してみてください。そして選択を解除してから通常のグループ選択を行ってグループ化が維持されていることを確認してください。

フィルとストローク

Inkscape の多くの機能は ダイアログ を利用しています。おそらくオブジェクトに色をつける最も簡単な方法は、表示メニューからスウォッチダイアログを開いて、オブジェクトを選択し、スウォッチをクリックして色を塗る (フィルの色を変える) ことでしょう。

もっと有効なのはフィル/ストロークダイアログを開くことです (Shift+Ctrl+F)。 下のシェイプを選択してフィル/ストロークダイアログを開いてください。

An example image

このダイアログには 3 つのタブ、すなわち、フィル、ストロークの塗り、ストロークスタイルがあります。フィルタブは選択したオブジェクトのフィル (内部の塗り) を編集します。タブのすぐ下のボタンでフィルの有無 (×のボタン)、単一色、線形グラデーション、放射状グラデーションを選択できます。上のシェイプでは単一色が有効になっています。

さらにその下には、数種のカラーピッカーがあります。各ピッカーはタブになっています (RGB、CMYK、HSL、そしてホイール)。おそらくもっとも便利なのは三角形を回して色を選択し、三角形の中で彩度を選択するホイールピッカーでしょう。すべてのピッカーはオブジェクトのアルファ値 (不透明度) を設定するためのスライダーを備えています。

オブジェクトを選択するとカラーピッカーは現在のオブジェクトのフィルとストローク値に更新されます (複数のオブジェクトが選択されている場合、平均の色が表示されます)。以下のサンプルや、自分で作ったオブジェクトで試してみましょう:

An example image

ストロークペイントタブで、ストローク (輪郭) を取り除くことや色と透明度の設定ができます:

An example image

最後のストロークスタイルタブでは、ストロークの幅とその他のパラメーターを設定できます:

An example image

最後に、フィルやストロークに単一色に代えて、グラデーションを適用できます:

An example image

単一色をグラデーションに切り替えるときに、新しく作成されたグラデーションはその前に使っていた色を不透明から透明に変化させます。グラデーションツールに切り替え (Ctrl+F1)、グラデーションハンドルをドラッグしてみましょう。グラデーションツールではグラデーションの方向と長さを線で連結されたコントロールが決めています。グラデーションハンドルを選択すると (青くハイライトされる)、フィルダイアログとストロークダイアログは選択したオブジェクトの色に代えてハンドルで示した色を適用します。

他にオブジェクトの色を変える便利な方法としてスポイトツール (F7) もあります。絵のどの部分でも クリック するだけで、抽出した色が選択中のオブジェクトのフィルに (Shift+クリックでストロークの色に) 適用されます。

複製、整列、配置

もっとも一般的な操作の一つにオブジェクトの複製があります (Ctrl+D)。複製は正確に元のオブジェクトの上に位置し選択状態になってるので矢印キーやマウスでドラッグすることで移動できます。練習として下の黒い正方形の行に、正方形の複製を並べて埋め尽くしてみましょう:

An example image

Chances are, your copies of the square are placed more or less randomly. This is where the Align and Distribute dialog (Shift+Ctrl+A) is useful. Select all the squares (Shift+click or drag a rubberband), open the dialog and press the “Center on horizontal axis” button, then the “Make horizontal gaps between objects equal” button (read the button tooltips). The objects are now neatly aligned and distributed equispacedly. Here are some other alignment and distribution examples:

An example image

Z 軸順序

Z 軸順序はオブジェクトを描くときの重なりの順序、すなわちどのオブジェクトが上になって他のオブジェクトを隠しているかを意味します。オブジェクトメニューにある 2 つのコマンド、最前面へ (Home キー)、最背面へ (End キー) は選択したオブジェクトを現在のレイヤーの Z 軸順序の最前面、最背面に移動します。もう 2 つのコマンド、前面へ (PgUp) と背面へ (PgDn) は選択したオブジェクトを 1 つだけ前後に移動、すなわち選択していないオブジェクトを 1 つかわして移動していくということです (選択オブジェクトが重なっている場合のみ。もし選択したオブジェクトを覆い隠している/いないものが何もない時、前面へと背面へはそれぞれ最前面、最背面に移動したことになります)。

これらのコマンドを使って左の楕円が一番上、右の楕円が一番下にくるように下のオブジェクトの Z 軸順序を反転してみましょう:

An example image

Tab は非常に便利なショートカットキーです。もし何も選択されていない場合には一番下にあるオブジェクトを、さもなければ Z 軸順序でみて選択されたオブジェクトの上にあるオブジェクトを選択します。 Shift+Tab はその逆、最上位のオブジェクトから下に向かって働きます。新しく作ったオブジェクトは一番上に重ねられるので、何も選択しないで Shift+Tab を押すと最後に作ったオブジェクトが選択されます。上の重なり合った楕円上で TabShift+Tab キーの練習をしてください。

隠れているオブジェクトの選択とドラッグでの選択

他のオブジェクトの下にあって隠れているオブジェクトはどうやって選択したらいいのでしょう? 上のオブジェクトが (半) 透明なら下のオブジェクトを見ることはできますが、クリックすると必要としていない上のオブジェクトが選択されてしまいます。

ここで Alt+クリック の出番です。はじめの Alt+クリック では普通のクリックと同じように 1 番上のオブジェクトが選択されます。しかし、同じ場所で次に Alt+クリック を行うと 1 番上のオブジェクトのにあるオブジェクトが、次のクリックでは、さらにその下が選択されます。こうして Alt+クリック を何回か行うとクリックした点にあるオブジェクトの Z 軸順序の重なりを前面から背面に循環します。最下層のオブジェクトまで到達すると、次の Alt+クリック で再び最上位のオブジェクトが選択されます。

[Linux の場合、Alt+クリックが適切に動作せず、Inkscape のウィンドウを動かしてしまうかもしれません。これはウィンドウマネージャーが Alt+クリックをウィンドウ操作のキーイベントとして受け付けてしまうためです。これを解決するには、ウィンドウマネージャーのウィンドウの振る舞いに関する設定から、それをオフにするか、他の修飾キー (例えば Windows キーなど) を使ったキー割り当てに変更してください。Inkscape およびその他のアプリケーションで Alt キーを自由に使用できるようになります。]

これはこれで良いのですが、表面にないオブジェクトを選択したとしてそれで何ができるのでしょう? 変形できるし、選択ハンドルをドラッグすることもできますが、オブジェクト自体をドラッグすると選択はリセットされ最上位のオブジェクトが選択されてしまいます (これはクリックアンドドラッグの設計がそうなってるためです。選択オブジェクトをドラッグする場合カーソル位置の (最上位) のオブジェクトがまず選択されるのです)。Inkscape に他の何かを選択せずに 今選択されているものをドラッグするよう知らせるには Alt+ドラッグ を使います。こうすればマウスをどこでドラッグしても現在の選択オブジェクトを移動できます。

緑の半透明の矩形の中にある2つの茶色のシェイプで Alt+クリックAlt+ドラッグ を練習してみましょう:

An example image

Selecting similar objects

Inkscape can select other objects similar to the object currently selected. For example, if you want to select all the blue squares below first select one of the blue squares, and use Edit > Select Same > Fill Color from the menu. All the objects with a fill color the same shade of blue are now selected.

An example image

In addition to selecting by fill color, you can select multiple similar objects by stroke color, stroke style, fill & stroke, and object type.

最後に

これで基本チュートリアルを終わります。Inkscape にはもっとたくさんの機能があります。しかしここで説明したテクニックですでに簡単かつ有用なグラフィックを作成することができるでしょう。もっと複雑な作業については ヘルプ > チュートリアル から上級、その他のチュートリアルを見るとよいでしょう。