Inkscape tutorial: Basique

Ce didacticiel présente les bases de l'utilisation d'Inkscape. Il s'agit d'un document Inkscape : vous pouvez le visionner, le modifier, en copier des éléments ou même le sauvegarder.

Le didacticiel basique aborde la navigation sur le canevas, la gestion des documents, les bases des outils de formes, la transformation d'objets à l'aide du sélecteur, les techniques de sélection, le groupement, le paramétrage du fond et du contour, l'alignement et la superposition. Pour des sujets plus avancés, consultez les autres didacticiels dans le menu Aide.

Se déplacer sur le canevas

Il y a plusieurs façons de se déplacer sur le canevas. Utilisez le raccourci Ctrl+flèche pour vous déplacer avec le clavier (essayez donc dès maintenant de faire défiler ce document vers le bas). Vous pouvez aussi agripper et déplacer le canevas en enfonçant le bouton du milieu de la souris. Ou bien, vous pouvez utiliser les barres de défilement (Ctrl+B permet de les afficher/masquer). La molette de la souris permet les déplacements verticaux, et même horizontaux en combinaison avec la touche Maj.

Zoomer et dézoomer

Le moyen le plus simple est d'utiliser les touches et + (ou =). Vous pouvez aussi zoomer avec Ctrl+clic milieu ou Ctrl+clic droit, et dézoomer avec Maj+clic milieu ou Maj+clic droit, ou bien faire tourner la molette de la souris tout en appuyant sur Ctrl. Vous pouvez aussi cliquer sur le champ de saisie (dans le coin en bas à droite de la fenêtre), y saisir une valeur de zoom, et la valider en appuyant sur la touche Entrée. Enfin, il reste l'outil de zoom (dans la barre d'outils à gauche) qui vous permet de définir une région sur laquelle zoomer à l'aide de la souris.

Inkscape garde aussi en mémoire un historique des niveaux de zoom. Appuyez sur la touche ` pour revenir au niveau de zoom précédent et utilisez Maj+` pour retourner au suivant.

Les outils d'Inkscape

La barre d'outils verticale à gauche affiche les outils de dessin et d'édition d'Inkscape. En haut de la fenêtre, juste en dessous des menus, la barre de commandes affiche les boutons des commandes générales tandis que la barre de contrôle des outils montre les contrôles spécifiques à chaque outil. La barre d'état en bas de la fenêtre affiche des indications et des messages qui peuvent vous aider dans votre travail.

De nombreuses opérations peuvent être effectuées avec des raccourcis clavier. Pour consulter tous les raccourcis disponibles, ouvrez le menu Aide > Clavier et souris.

Créer et gérer des documents

Pour créer un nouveau document vide, utilisez Fichier > Nouveau ou appuyez sur Ctrl+N. Pour créer un nouveau document à partir d'un des nombreux modèles d'Inkscape, utilisez Fichier > Nouveau à partir d'un modèle… ou appuyez sur Ctrl+Alt+N.

Pour ouvrir un fichier SVG existant, utilisez Fichier > Ouvrir (Ctrl+O). Pour enregistrer, utilisez Fichier > Enregistrer (Ctrl+S), ou Enregistrer sous… (Maj+Ctrl+S) pour sauver sous un nouveau nom (Inkscape est encore assez instable, donc pensez à enregistrer votre travail fréquemment !).

Inkscape utilise le format SVG (Scalable Vector Graphics) pour ses fichiers. Le format SVG est un standard ouvert largement utilisé par les logiciels de graphisme. Les fichiers SVG sont basés sur le format XML et peuvent être édités à l'aide de n'importe quel éditeur de texte ou XML (ou avec Inkscape, bien sûr). En plus du SVG, Inkscape peut importer et exporter des documents dans d'autres formats (EPS, PNG…).

Inkscape ouvre une nouvelle fenêtre pour chaque document. Naviguez entre elles avec votre gestionnaire de fenêtres (avec le raccourci Alt+Tab par exemple), ou utilisez le raccourci Ctrl+Tab, qui permet de circuler parmi les documents ouverts (créez dès maintenant un nouveau document pour tester la navigation entre le tutoriel et le nouveau document). Note : Inkscape traite ces fenêtres comme les onglets dans un navigateur web, ce qui signifie que le raccourci Ctrl+Tab ne fonctionne qu'avec des documents s'exécutant dans la même instance. Si vous ouvrez plusieurs fichiers depuis un navigateur de fichiers ou exécutez plusieurs instances d'Inkscape, cela ne fonctionnera pas.

Créer des formes

Il est temps de passer aux formes ! Cliquez sur l'outil Rectangle dans la barre d'outils (ou appuyez sur F4) et avec un cliquer-glisser, créez un rectangle, soit dans un nouveau document vide, soit dans celui-ci :

An example image

Comme vous pouvez le voir, par défaut, les rectangles sont bleus, avec un contour noir, et complètement opaques. Nous allons voir comment changer cela ci-dessous. Avec les autres outils, vous pouvez aussi créer des ellipses, des étoiles et des spirales :

An example image

Ces outils sont les outils de formes. Chaque forme créée affiche une ou plusieurs poignées en forme de diamant ; essayez de les déplacer pour voir comment la forme réagit. Pour chacun des outils de formes, la barre de contrôle fournit une façon supplémentaire de modifier la forme ; ces contrôles affectent la forme sélectionnée (c'est-à-dire celle qui a ses poignées affichées) et définissent les paramètres par défaut qui s'appliqueront lors de la création de toute nouvelle forme.

Pour annuler votre dernière action, appuyez sur Ctrl+Z (ou si vous changez d'avis, vous pouvez restaurer l'action annulée avec Maj+Ctrl+Z).

Déplacer, redimensionner et tourner

L'outil d'Inkscape le plus utilisé est le sélecteur. Cliquez sur le bouton tout en haut (celui avec la flèche) dans la barre d'outils (ou appuyez sur F1 ou sur la barre d'espace). Vous pouvez alors sélectionner n'importe quel objet sur le canevas. Ainsi, sélectionnez le rectangle ci-dessous.

An example image

Vous devriez voir apparaître huit poignées en forme de flèche autour des bords de l'objet. Vous pouvez maintenant :

Cliquez à nouveau sur le rectangle. Les poignées changent de forme. Vous pouvez maintenant :

Toujours avec le sélecteur, dans les champs numériques de la barre supérieure, vous pouvez définir précisément les coordonnées (X et Y) et la taille (L et H) de la sélection.

Transformer à l'aide des raccourcis clavier

Une des capacités d'Inkscape le distinguant d'autres éditeurs vectoriels est la possibilité d'utiliser le clavier de façon intensive. Il n'y a pratiquement pas d'action ou de commande qui ne soit pas accessible depuis le clavier, et la transformation d'objet ne fait pas exception.

Vous pouvez utiliser le clavier pour déplacer (flèches), redimensionner (< et >) et tourner ([ et ]) les objets. L'incrément par défaut de modification des dimensions et de déplacement est de 2 px ; avec la touche Maj, le déplacement est multiplié par 10. Ctrl+> et Ctrl+< redimensionnent respectivement de 200 % et 50 % par rapport à l'original. L'incrément de rotation par défaut est de 15 degrés ; ou de 90 degrés si vous appuyez sur Ctrl.

Mais les transformations à l'échelle du pixel sont peut-être les plus utiles, obtenues par la combinaison de la touche Alt avec un raccourci. Par exemple, Alt+flèche déplace la sélection d'1 pixel, au zoom courant (c'est-à-dire d'un pixel sur l'écran, à ne pas confondre avec l'unité px qui est une unité SVG de longueur indépendante du zoom). Ceci implique que si vous zoomez plus, un raccourci Alt+flèche provoquera un mouvement absolu plus petit, correspondant toujours à un pixel à l'écran. Il est ainsi possible de positionner des objets avec une précision arbitraire simplement en zoomant ou dézoommant selon les besoins.

De même, Alt+> et Alt+< changent les dimensions de la sélection d'1 pixel à l'écran, et Alt+[ et Alt+] la tournent de telle façon que le point le plus éloigné du centre bouge d'un seul pixel à l'écran.

Note : il se peut que les utilisateurs de Linux n'obtiennent pas les résultats attendus avec Alt+flèche et d'autres combinaisons si leur gestionnaire de fenêtres récupère les événements des touches avant qu'elles n'atteignent l'application Inkscape. Une des solutions consiste à changer la configuration du gestionnaire de fenêtres pour éviter cela.

Sélections multiples

Avec Maj+clic, vous pouvez simultanément sélectionner plusieurs objets. Avec un cliquer-glisser, vous pouvez aussi définir une zone autour des objets ; on appelle ceci une sélection par bande étirable (le sélecteur crée une bande étirable quand on commence un cliquer-glisser sur une zone vide ; mais si vous appuyez sur Maj avant de cliquer, Inkscape forcera la création d'une bande étirable). Entraînez-vous avec les trois formes ci-dessous :

An example image

Maintenant, utilisez la bande étirable (avec un cliquer-glisser ou Maj+cilquer-glisser) à titre d'exemple pour sélectionner les deux ellipses mais pas le rectangle :

An example image

Tout objet sélectionné affiche une marque de sélection — par défaut, un cadre en pointillés. Ceci permet de distinguer facilement ce qui est sélectionné de ce qui ne l'est pas. Si, par exemple, vous sélectionnez les deux ellipses et le rectangle ci-dessus, sans ces indications, il vous sera difficile de savoir si les ellipses sont bien sélectionnées ou non.

Maj+clic sur un objet sélectionné l'exclut de la sélection. Sélectionnez les trois objets ci-dessus, puis utilisez Maj+clic pour exclure les deux ellipses de la sélection, en n'y conservant que le rectangle.

Appuyer sur Échap désélectionne tous les objets. Ctrl+A sélectionne tous les objets du calque courant (si vous n'avez pas créé de calque, vous sélectionnerez tous les objets du document).

Grouper

Plusieurs objets peuvent être réunis dans un groupe. Un groupe se comporte comme un simple objet quand vous le déplacez ou le transformez. Ci-dessous, les trois objets de gauche sont indépendants ; les trois mêmes objets de droite sont groupés. Essayez de les déplacer.

An example image

Pour créer un groupe, sélectionnez un ou plusieurs objets et appuyez sur Ctrl+G. Pour dégrouper un ou plusieurs groupes, sélectionnez-les et appuyez sur Ctrl+U. Les groupes peuvent eux-mêmes être groupés, comme n'importe quels autres objets ; de tels groupes récursifs peuvent avoir une profondeur quelconque. Cependant, Ctrl+U ne dégroupe que le dernier niveau de groupe de la sélection ; vous devrez répéter Ctrl+U si vous voulez dégrouper complètement des groupes de groupes.

Cependant, vous n'avez pas nécessairement besoin de dégrouper pour éditer un objet au sein d'un groupe. Un simple Ctrl+clic sur un objet permet de le sélectionner seul et de l'éditer, et Maj+Ctrl+clic sur plusieurs objets (inclus ou non dans des groupes quelconques) permet d'effectuer une sélection multiple. Essayez de déplacer ou transformer sans les dégrouper les formes du groupe ci-dessus à droite, puis de les désélectionner, et resélectionnez le groupe normalement pour vérifier qu'elles sont toujours groupées.

Fond et contour

La façon la plus simple de donner une couleur à un objet est probablement de sélectionner un objet, puis de cliquer sur une couleur dans la palette en bas afin de le peindre (changer sa couleur de fond). Vous pouvez également ouvrir la boîte de dialogue Palettes depuis le menu Affichage (ou appuyer sur Maj+Ctrl+W), sélectionner un objet, et cliquer sur une couleur pour le peindre.

La boîte de dialogue Fond et contour du menu Objet (ou accessible avec Maj+Ctrl+F) est plus puissante. Sélectionnez la forme ci-dessous et ouvrez la boîte de dialogue Fond et contour.

An example image

Vous constatez que la boîte de dialogue a trois onglets : Fond, Contour et Style du contour. L'onglet Fond permet d'éditer le fond (l'intérieur) du ou des objet(s) sélectionné(s) (on parle aussi de remplissage — « fill » en anglais —, mais nous avons choisi une traduction brève pour des contraintes techniques). L'utilisation des boutons juste sous l'onglet vous permet de choisir le type de fond : transparent (aucun fond, le bouton avec un X), couleur de fond uniforme, ou encore dégradé linéaire ou radial. Pour la forme ci-dessus, le bouton Couleur uniforme devrait être sélectionné.

Plus bas, vous pouvez voir la collection de sélecteurs de couleur chacun dans un onglet : RVB, TSL, CMJN, et Roue. Le plus pratique est peut-être la roue, dans laquelle vous pouvez tourner un triangle pour choisir une teinte sur la roue, puis une nuance dans le triangle. Tous les sélecteurs de couleur comportent une réglette pour définir l'alpha (opacité) de(s) objet(s) sélectionné(s).

Quand vous sélectionnez un objet, la boîte de dialogue Fond et contour est mise à jour pour afficher ses fond et contour actuels (quand plusieurs objets sont sélectionnés, elle affiche la moyenne de leurs couleurs). Jouez avec les exemples ci-dessous ou créez les vôtres :

An example image

En utilisant l'onglet Contour, vous pouvez enlever le contour d'un objet ou lui attribuer n'importe quelle couleur ou transparence :

An example image

Le dernier onglet, Style de contour, vous permet de définir la largeur et les autres paramètres du contour :

An example image

Enfin, vous pouvez utiliser des dégradés au lieu de couleurs uniformes pour les fonds comme pour les contours :

An example image

Quand vous passez d'une couleur uniforme à un dégradé, le dégradé nouvellement créé utilise cette même couleur, allant d'opaque à transparente. Utilisez l'outil de Dégradé (Ctrl+F1) pour déplacer les poignées de dégradé — les poignées de contrôle connectées par des lignes qui définissent la direction et la longueur du dégradé. Quand l'une de ces poignées est sélectionnée (surlignée en bleu), la boîte de dialogue Fond et contour permet de définir la couleur liée à cette poignée à la place de la couleur de l'objet sélectionné.

Une autre manière pratique de changer la couleur d'un objet est d'utiliser l'outil Pipette (F7). Un simple clic n'importe où sur le dessin avec cet outil permet d'attribuer la couleur ainsi capturée au fond de l'objet sélectionné (Maj+clic l'attribuera à son contour).

Duplication, alignement, distribution

Une des opérations les plus courantes est la duplication d'un objet (Ctrl+D). Le dupliqué est placé juste au-dessus de l'original et est sélectionné, vous permettant ainsi de le déplacer à la souris ou avec des raccourcis. Pour vous exercer, essayez de remplir la ligne avec des copies du carré noir ci-dessous :

An example image

Il y a des chances que vos copies du carré ne soient pas bien alignées. La boîte de dialogue Aligner et distribuer (Maj+Ctrl+A) devient alors utile. Sélectionnez tous les carrés (avec Maj+clic ou une bande étirable), ouvrez la boîte de dialogue et appuyez sur le bouton « Centrer selon l'axe horizontal », puis sur « Distribuer des distances horizontalement entre les objets » (consultez les indications affichées quand la souris passe au-dessus des boutons). Les objets sont maintenant alignés et distribués de façon équidistante. Voici d'autres exemples d'objets alignés et distribués :

An example image

Ordre d'empilement

Lorsque plusieurs objets se recouvrent, il est possible de définir l'ordre dans lequel ils sont empilés, c'est-à-dire quels objets sont en haut et masquent les autres (paramètre z-order). Les deux commandes du menu Objet, Monter au premier plan (touche Origine) et Descendre à l'arrière-plan (touche Fin), feront passer les objets sélectionnés tout au-dessus ou tout au fond de l'empilement du calque actuel. Deux autres commandes, Monter (Page précédente) et Descendre (Page suivante), les enfouiront ou émergeront d'un cran seulement, c'est-à-dire juste au-delà d'un objet non sélectionné dans l'empilement (seuls les objets chevauchant la sélection comptent, en fonction de leur boîte englobante).

Exercez-vous à l'utilisation de ces commandes en inversant la superposition des objets ci-dessous, de telle sorte que l'ellipse la plus à gauche soit tout au-dessus et la plus à droite tout au fond :

An example image

Un raccourci de sélection très utile est la touche Tab. Si rien n'est sélectionné, il sélectionne l'objet le plus au fond ; sinon, il sélectionne l'objet juste au-dessus de l'objet sélectionné dans l'empilement. Maj+Tab fait l'inverse, commençant par l'objet tout au-dessus en allant vers le fond. Comme les objets que vous créez sont ajoutés au-dessus de la superposition, appuyer sur Maj+Tab quand aucun objet n'est sélectionné vous permettra de retrouver facilement le dernier objet que vous avez créé. Essayez Tab et Maj+Tab sur les ellipses superposées ci-dessus.

Sélectionner et déplacer des objets couverts

Que faire si l'objet dont vous avez besoin est caché derrière un autre objet ? Vous pouvez encore voir l'objet en dessous si celui du dessus est (partiellement) transparent, mais en cliquant dessus, vous sélectionnerez l'objet du dessus, pas celui dont vous avez besoin.

Pour cela, il faut utiliser Alt+clic. Alt+clic sélectionne d'abord l'objet du dessus, comme un clic normal ; mais le Alt+clic suivant au même endroit sélectionne l'objet juste en dessous ; et ainsi de suite. Donc, plusieurs Alt+clic à la suite vous permettront de naviguer du dessus vers le fond à travers la superposition de différents objets sous le pointeur de la souris. Quand l'objet du fond est sélectionné, un Alt+clic de plus sélectionne de nouveau l'objet du dessus.

[Si vous êtes sous Linux, vous pourriez éventuellement vous apercevoir que Alt+clic ne fonctionne pas correctement, mais déplace la fenêtre Inkscape en totalité. C'est parce que votre gestionnaire de fenêtres a réservé le raccourci Alt+clic pour une autre action. Pour corriger cela, il faut trouver l'option de configuration du comportement des fenêtres de votre gestionnaire de fenêtres, puis la désactiver ou bien lui associer une autre touche (par exemple Super — aussi appelée « Windows »), afin qu'Inkscape et les autres applications puissent librement utiliser la touche Alt.]

Bien, mais une fois l'objet recouvert sélectionné, qu'en faire ? Vous pouvez le transformer grâce aux raccourcis et déplacer ses poignées de sélection. Cependant, déplacer l'objet lui-même resélectionnera l'objet tout au-dessus à nouveau (le cliquer-glisser est conçu comme cela : d'abord sélectionner l'objet le plus haut juste sous le curseur puis déplacer la sélection). Pour demander à Inkscape de déplacer la sélection présente (éventuellement en dessous d'autres objets) sans rien sélectionner d'autre, utilisez Alt+cliquer-glisser. Cela vous permettra de déplacer la sélection actuelle où que vous placiez la souris.

Essayez Alt+clic et Alt+cliquer-glisser sur les deux formes brunes sous le rectangle vert transparent :

An example image

Sélectionner des objets similaires

Inkscape peut sélectionner automatiquement tous les objets ayant un point commun. Par exemple, si vous souhaitez sélectionner tous les carrés bleus ci-dessous, sélectionnez tout d'abord l'un d'entre eux, puis utilisez Édition > Sélectionner même > Couleur de fond dans le menu. Tous les objets avec la même teinte de bleu seront alors sélectionnés.

An example image

Vous pouvez non seulement sélectionner par couleur de fond, mais également par couleur de contour, style de contour, fond et contour, et type d'objet.

Conclusion

Ceci conclut le didacticiel basique. Inkscape offre beaucoup d'autres fonctionnalités, mais les techniques décrites ci-dessus vous permettront déjà de créer des dessins simples mais utiles. Pour un usage plus avancé, consultez le didacticiel avancé dans Aide > Didacticiels.