Inkscape tutorial: Grundlagen

Dieses Tutorial beschreibt die Grundlagen der Verwendung von Inkscape. Es ist ein normales Inkscape-Dokument, das man anschauen, verändern, aus dem man Teile herauskopieren, und das man speichern kann.

Das Grundlagentutorial behandelt die Themen Seitennavigation, Dokumentenerstellung, Grundlagen der Formwerkzeuge, Techniken der Objektauswahl, Objektmanipulation mit dem Auswahlwerkzeug, Gruppierung, Ändern von Füllfarbe und Kontur, Ausrichten von Objekten und die Stapelordnung. Anleitungen zu anspruchsvolleren Themen finden Sie in den anderen Tutorien im Hilfe-Menü.

Den Arbeitsbereich verschieben

Es gibt viele Möglichkeiten, den Arbeitsbereich zu verschieben. Entweder benutzt man Strg+Pfeiltasten zum Verschieben mit der Tastatur, oder man bewegt den Arbeitsbereich mit der mittleren Maustaste (probieren Sie das doch gleich mal aus). Natürlich können Sie auch die seitlichen Verschiebeleisten verwenden, die mit Strg+B ein- und ausgeblendet werden können. Man kann auch das Mausrad verwenden, um den Arbeitsbereich vertikal zu verschieben; durch gleichzeitiges Drücken der Umschalt-Taste auch in horizontaler Richtung.

Herein- und Herauszoomen

Die einfachste Möglichkeit zu zoomen bieten die Tasten - und + (oder =). Alternativ kann man per Strg+Mittelklick oder Strg+Rechtsklick hereinzoomen bzw. mit Umschalt+Mittelklick oder Umschalt+Rechtsklick herauszoomen, oder aber man dreht das Mausrad bei gedrückter Strg-Taste. Außerdem lässt sich der Zoomwert in Prozent direkt in das Zoomeingabefeld (in der rechten unteren Ecke des Dokumentenfensters) eingeben und mit der Eingabetaste bestätigen. Außerdem gibt es da noch das Zoom-Werkzeug (links in der Werkzeugleiste), mit dem Sie in ein Gebiet hereinzoomen können, indem Sie ein Rechteck darum ziehen.

Inkscape merkt sich die gewählten Zoomstufen, die Sie in der aktuellen Sitzung verwendet haben. Durch Drücken der `-Taste springt man zur vorherigen, durch Umschalt+` zur nächsten Zoomstufe (Anm. d. Übersetzers: Mit einer deutschen Tastatur nicht möglich.).

Inkscape-Werkzeuge

Die senkrechte Werkzeugleiste auf der linken Seite zeigt Inkscapes Zeichen- und Bearbeitungswerkzeuge. Im oberen Bereich des Fensters, unter der Fensterleiste, liegt die Befehlsleiste mit Schaltflächen für verschieden allgemeine Befehle, darunter die Werkzeugeinstellungsleiste für werkzeugabhängige Eingaben. Die Statusleiste am unteren Fensterrand zeigt nützliche Hinweise und Informationen an, während man arbeitet.

Viele Funktionen sind durch Tastaturkurzbefehle erreichbar. Öffnen Sie Hilfe > Referenz der Tasten- und Mausbefehle, um alle Befehle zu sehen.

Erstellen und Verwenden von Dokumenten

Um ein neues, leeres Dokument zu erzeugen, benutzt man Datei > Neu oder drückt Strg+N. Um ein neues Dokument aus einer der vielen verfügbaren Vorlagen für Inkscape zu erstellen, verwendet man Datei > Neu aus Vorlage oder drückt Strg+Alt+N.

Ein bestehendes SVG-Dokument öffnet man mit Datei > Öffnen... (Strg+O). Zum Speichern wählt man Datei > Speichern (Strg+S), oder Speichern unter… (Umschalt+Strg+S), um das Dokument unter einem neuen Namen zu speichern (Inkscape kann gelegentlich noch abstürzen, daher besser öfter speichern!).

Inkscape verwendet das SVG-Format (Scalable Vector Graphics) für seine Dateien. SVG ist ein offener Standard, der von vielen Zeichenprogrammen unterstützt wird. SVG-Dateien basieren auf dem XML-Standard und können mit jedem Text- oder XML-Editor (zusätzlich zu dem in Inkscape, natürlich) verändert werden. Neben SVG kann Inkscape auch einige andere Formate importieren und exportieren (z. B. EPS und PNG).

Inkscape öffnet ein separates Programmfenster für jedes einzelne Dokument. Man kann mit dem Fenster-Manager dazwischen wechseln (z. B. durch Alt+Tab) oder auch mit dem Inkscape-eigenen Kurzbefehl Strg+Tab, der durch alle geöffneten Dokument-Fenster wandert (erstellen Sie jetzt ein neues Dokument und schalten Sie zur Übung zwischen diesem und dem Tutorial hin und her). Hinweis: Inkscape behandelt diese Fenster wie Reiter in einem Webbrowser. Das bedeutet, dass der Kurzbefehl

Formen erstellen

Nun ist es Zeit, ein paar schicke Formen zu erstellen! Klicken Sie auf das Rechteckwerkzeug in der Werkzeugleiste links (oder drücken Sie F4) und klicken und ziehen Sie, entweder in einem neuen, leeren Dokument oder gleich hier:

An example image

Wie Sie sehen können, sind Standard-Rechtecke blau gefüllt, mit einer schwarzen Kontur (der Umrandung), und vollständig deckend. Wir werden noch sehen, wie man das ändern kann. Mit anderen Werkzeugen lassen sich auch Ellipsen, Sterne und Spiralen erstellen:

An example image

Diese Werkzeuge werden unter dem Begriff Form-Werkzeuge zusammengefasst. Jede erzeugte Form zeigt einen oder mehrere rautenförmige Anfasser. Ziehen Sie mit der Maus daran, um zu sehen wie sich die Form dadurch verändert. Die Werkzeugeinstellungsleiste für Formen bietet ebenfalls die Möglichkeit, die Form zu verändern. Die Einstellungen verändern die aktuell ausgewählten Objekte (die, die die entsprechenden Anfasser haben) und setzt den Standard für alle neuen Objekte.

Um die letzte Aktion rückgängig zu machen, drückt man Strg+Z. (Oder, wenn Sie es sich wieder anders überlegen, benutzen Sie Wiederherstellen durch Umschalt+Strg+Z.)

Bewegen, Größe ändern, Drehen

Das am häufigsten verwendete Werkzeug in Inkscape ist das Auswahlwerkzeug. Klicken Sie den obersten Knopf (mit dem Pfeil) in der Werkzeugleiste, oder drücken Sie F1 oder Leertaste. Nun können Sie jedes Objekt auf der Seite auswählen. Probieren Sie das an dem Rechteck unten.

An example image

Sie sehen jetzt acht pfeilförmige Anfasser um das markierte Objekt. Jetzt haben Sie mehrere Möglichkeiten:

Nun klicken Sie noch einmal auf das Rechteck. Die Anfasser sehen jetzt anders aus. Jetzt gibt es folgende Möglichkeiten:

Wenn man das Auswahlwerkzeug verwendet und das Objekt ausgewählt ist, kann man auch die Eingabefelder (über der Zeichenfläche) benutzen, um genaue Werte für die Koordinaten (X und Y) und die Größe (B und H) einzugeben.

Verändern mit der Tastatur

Eine der Eigenschaften von Inkscape, die es von vielen anderen Vektorzeichenprogrammen unterscheidet, ist die gute Tastaturbedienbarkeit. Es gibt fast keinen Befehl oder keine Aktion, die nicht mit der Tastatur ausführbar sind, und Objektmanipulation ist da keine Ausnahme.

Man kann Objekte mit der Tastatur verschieben (Pfeil-Tasten), ihre Größe ändern (<- und >-Tasten) und sie drehen ([- und ]-Tasten). Die Standardschrittweite für Bewegung und Größenänderung mit der Tastatur ist 2 px, mit Umschalt das Zehnfache davon. Strg+< und Strg+> vergrößern auf 200% oder verkleinern auf 50% der Originalgröße. Standardmäßig werden Objekte in Schritten von 15° gedreht, mit gedrückter Strg-Taste in 90°-Schritten.

Besonders nützlich sind pixelgenaue Manipulationen durch gleichzeitiges Drücken von Alt mit den entsprechenden Tasten. Mit Alt+Pfeiltaste verschiebt man das markierte Objekt um 1 Pixel bei gewähltem Zoomfaktor (also 1 Bildschirm-Pixel, nicht zu verwechseln mit der px-Einheit, welche eine SVG-Längeneinheit unabhängig vom Zoomfaktor ist). Das bedeutet, wenn man hineinzoomt, dann entspricht ein einmaliger Druck auf Alt+Pfeil einer kleineren absoluten Bewegung, obwohl es auf dem Bildschirm immer noch eine Bewegung um 1 Pixel ist. So ist es möglich, Objekte mit einer beliebig hohen Präzision zu positionieren, einfach indem man hinein- oder herauszoomt.

Genauso ändern Alt+< und Alt+> die Objektgröße so, das die sichtbare Größe um jeweils ein Bildschirm-Pixel verändert wird. Die Tasten Alt+[ und Alt+] drehen den Punkt, der am weitesten vom Zentrum entfernt ist, um ein Bildschirm-Pixel weiter.

Anmerkung: Linux-Benutzer erhalten möglicherweise nicht den gewünschten Effekt mit Alt+Pfeiltaste und ein paar anderen Tastenkombinationen, wenn ihr Fenstermanager diese Tastendrücke abfängt, bevor sie zu Inkscape gelangen. Eine Lösung ist es, die Einstellungen des Fenstermanagers entsprechend zu ändern.

Mehrfachauswahl

Man kann mehrere Objekte gleichzeitig durch Umschalt+Klick, oder durch Ziehen um die Objekte herum auswählen. Letzteres wird Gummibandauswahl genannt. (Das Auswahlwerkzeug erzeugt das Gummiband durch Ziehen über einem leeren Teil der Seite, aber immer auch, wenn vor dem Ziehen Umschalt gedrückt wird.) Üben Sie das Markieren aller drei Formen hier unten:

An example image

Jetzt benutzen Sie das Gummiband (durch Ziehen oder Umschalt+Ziehen), um beide Ellipsen, aber nicht das Rechteck zu markieren:

An example image

Jedes einzelne Objekt einer Auswahl zeigt einen Objektrahmen – normalerweise einen gestrichelten, rechteckigen Rahmen. So kann man ganz einfach sehen, was ausgewählt ist und was nicht. Wenn man zum Beispiel beide Ellipsen und das Rechteck auswählt, dann hätte man es ohne diese Hinweise schwer zu sagen, ob die Ellipsen markiert sind oder nicht.

Umschalt+Klick auf ein markiertes Objekt entfernt es aus der Auswahl. Wählen Sie alle drei Objekte oben aus, dann benutzen Sie Umschalt+Klick, um beide Ellipsen aus der Auswahl herauszunehmen und nur das Rechteck ausgewählt zu lassen.

Nach einem Druck auf Esc sind keine Objekte mehr ausgewählt. Strg+A wählt dagegen alle Objekte der momentan aktivierten Ebene aus. (Wenn Sie keine weiteren Ebenen erstellt haben, entspricht das allen Objekten im Dokument).

Gruppieren

Mehrere Objekte können zu einer Gruppe zusammengefasst werden. Eine Gruppe verhält sich wie ein einzelnes Objekt, wenn man sie verschiebt oder mit den Anfassern verformt. Die drei Objekte unten links sind alle noch einzeln; die gleichen drei Objekte auf der rechten Seite sind gruppiert. Versuchen Sie, die Gruppe zu verschieben.

An example image

Um eine Gruppe zu erzeugen, wählt man ein oder mehrere Objekte aus und drückt Strg+G. Um die Gruppierung bei einer oder mehreren Gruppen aufzuheben, markiert man diese und drückt Strg+U. Gruppierungen können selbst auch gruppiert werden, wie jedes andere Objekt auch. Solche verschachtelten Gruppierungen können beliebig tief weitergeführt werden. Einmaliges Strg+U hebt nur die oberste (letzte) Gruppierung einer ausgewählten Gruppe auf. Um alle Gruppierungen der Auswahl aufzuheben, müssen Sie Strg+U mehrfach drücken.

Es ist nicht unbedingt nötig, alle Gruppierungen aufzuheben, wenn man ein Objekt in einer Gruppe bearbeiten will. Strg+Klick auf ein solches Objekt wählt es aus und erlaubt, es zu bearbeiten. Um mehrere Objekte innerhalb oder außerhalb einer Gruppe auszuwählen, drücken Sie Umschalt+Strg+Klick. Versuchen Sie, einzelne Objekte in der Gruppe (oben rechts) zu verschieben oder zu verändern, ohne die Gruppierung aufzuheben. Anschließend heben Sie die Markierung wieder auf und markieren die Gruppe normal, um zu sehen, dass die Gruppierung erhalten geblieben ist.

Füllung und Kontur

Die wohl einfachste Möglichkeit, wie man ein Objekt einfärben kann, ist es auszuwählen und dann auf eines der farbigen Kästchen unterhalb der Zeichenfläche zu klicken (dies ändert die Füllfarbe). Alternativ kann der Farbmuster-Dialog vom Ansicht-Menü aus geöffnet werden (oder mittels Shift+Ctrl+W), das Objekt markiert werden, und ein Farbfeld angeklickt werden (auch dies ändert die Füllfarbe).

Viel leistungsfähiger ist der Dialog »Füllung und Kontur« aus dem Objekt-Menü (Umschalt+Strg+F). Wählen Sie das Objekt unten aus und öffnen Sie den Dialog.

An example image

Sie werden sehen, dass der Dialog drei Reiter hat: Füllung, Farbe der Kontur, und Muster der Kontur. Im Reiter »Füllung« ändert man die Füllfarbe (Innenfarbe) des markierten Objekts. Mit den Knöpfen direkt unter dem Reiter kann man die Füllungsart verändern: die Füllung ganz ausschalten (mit dem Knopf mit dem X), einfach (einfarbig) füllen, oder einen Linear- und Radialverlauf auswählen. Bei dem Objekt oben ist der Knopf »Einfache Farbe« aktiviert.

Weiter unten sieht man verschiedene Farbwahlmöglichkeiten. Jede hat einen eigenen Reiter: RGB, HSL, CMYK und Farbrad. Wahrscheinlich am praktischsten ist das Farbrad, bei dem man das Dreieck verdrehen kann, um den Farbton zu wählen und dann die gewünschte Helligkeit im Dreieck auswählt. Alle Farbwähler besitzen einen Schieberegler, um den Alpha-Kanal (die Deckkraft) der Objektfarbe einzustellen.

Immer, wenn Sie ein Objekt auswählen, zeigt der Farbwähler dessen aktuelle Farbe und Kontur. Bei mehr als einem markierten Objekt wird die Durchschnittsfarbe angezeigt. Üben Sie an diesen Beispielobjekten oder erzeugen Sie selbst welche:

An example image

Mit dem Reiter »Farbe der Kontur« kann man die Kontur (Außenlinie) des Objektes entfernen, oder ihr eine beliebige Farbe und Deckkraft zuordnen:

An example image

Der letzte Reiter »Muster der Kontur« dient zum Einstellen der Breite und anderer Eigenschaften der Kontur:

An example image

Statt einer einfachen Farbe kann man auch Farbverläufe für Füllung und/oder Kontur benutzen:

An example image

Wenn man von einer einfachen Farbe auf einen Farbverlauf umschaltet, hat der neue Farbverlauf an beiden Enden zunächst die zuvor eingestellte Farbe - an einem Ende ist diese voll deckend, am anderen komplett transparent. Schalten Sie zum Farbverlaufswerkzeug (Strg+F1), um die Verlaufs-Anfasser zu verschieben – das sind durch Linien verbundene Anfasser, mit denen man Richtung und Länge des Verlaufs einstellen kann. Wenn einer der Verlaufs-Anfasser ausgewählt ist (blau hervorgehoben), dann setzt der Dialog »Füllung und Kontur« nur die Farbe dieses einen Anfassers statt der Farbe des ganzen Objekts.

Eine andere praktische Möglichkeit, die Farbe eines Objektes zu ändern, ist die Pipette (F7). Klicken Sie einfach mit der Pipette auf die Zeichnung, und die dort gewählte Farbe wird automatisch als Füllfarbe für das aktuelle Objekt benutzt. (Umschalt+Klick ändert die Farbe der Kontur.)

Duplizieren, Ausrichten, Verteilen

Einer der häufigsten Arbeitsschritte ist das Duplizieren eines Objekts (Strg+D). Die Kopie des Objektes liegt danach direkt über dem kopierten Objekt und ist ausgewählt, so dass es sofort mit der Maus oder den Pfeiltasten verschoben werden kann. Versuchen Sie doch einmal zur Übung, Kopien des schwarzen Quadrats in einer Linie nebeneinander anzuordnen:

An example image

Es ist gut möglich, dass Ihre Quadrate jetzt einigermaßen zufällig platziert sind. Hier hilft der Dialog »Ausrichten und Verteilen« (Strg+Umschalt+A). Wählen Sie alle Quadrate aus (mit Umschalt+Klick oder dem Gummiband), öffnen Sie dann den Dialog und drücken »Zentren horizontal ausrichten«. Danach benutzen Sie »Horizontale Abstände zwischen Objekten ausgleichen« (lesen Sie die Tooltips der Schaltflächen). Die Objekte sind jetzt gleichmäßig ausgerichtet und verteilt. Hier sind weitere Übungsmöglichkeiten für Sie:

An example image

Z-Ordnung

Der Begriff Z-Ordnung beschreibt die Stapelordnung von Objekten in einer Zeichnung – d.h. welche Objekte oben liegen und dadurch andere, darunterliegende, Objekte verdecken. Die zwei Befehle im Objektmenü, »Nach ganz oben anheben« (die Pos 1-Taste) und »Nach ganz unten absenken« (die Ende-Taste), bringen das ausgewählte Objekt nach ganz oben oder ganz unten in der Z-Ordnung der aktuellen Ebene. Zwei weitere Befehle, »Anheben« (Bild hoch) und »Absenken« (Bild runter), heben oder senken das ausgewählte Objekt nur um eine Stufe; das heißt, sie bewegen das Objekt an einem einzigen, nicht ausgewählten, Objekt in der Z-Ordnung vorbei. (Dazu zählen nur Objekte, die mit ihrem Begrenzungsrahmen die Auswahl überdecken).

Üben Sie diese Befehle, indem Sie die Z-Ordnung der Objekte unten umkehren, so dass am Ende die ganz linke Ellipse oben und die ganz rechte Ellipse unten liegt:

An example image

Eine sehr nützliche Auswahlhilfe ist die Tab-Taste. Wenn nichts ausgewählt ist, dann wählt sie das unterste Objekt; andernfalls wählt sie das Objekt über den markierten Objekten in Z-Ordnung. Umschalt+Tab arbeitet genau anders herum – man beginnt beim obersten Objekt und arbeitet sich dann nach unten. Objekte, die man neu erzeugt, liegen zuoberst auf dem Stapel, und so wählt Umschalt+Tab praktischerweise das zuletzt erzeugte Objekt, solange nichts anderes markiert ist. Üben Sie Tab und Umschalt+Tab ein wenig an dem Stapel Ellipsen oben.

Verdeckte Objekte auswählen und verschieben

Wie kommt man an ein Objekt heran, das von einem anderen verdeckt wird? Es kann sein, das man das untere Objekt zwar sehen kann, wenn das obere Objekt (teilweise) durchsichtig ist. Doch bei dem Versuch, es auszuwählen, markiert man das obere Objekt und nicht das, das man haben möchte.

Dafür gibt es Alt+Klick. Mit dem ersten Alt+Klick wählt man das oberste Objekt, genau wie mit einem gewöhnlichen Klick. Das nächste Mal Alt+Klick an der gleichen Stelle wählt jedoch das Objekt unter dem obersten; dann das nächste darunter, noch eines tiefer u.s.w. Auf diese Weise kommt man durch mehrere Alt+Klicks nacheinander von ganz oben nach ganz unten, durch den ganzen Z-Ordnungsstapel von Objekten an der Stelle des Klicks. Wenn das unterste Objekt erreicht ist, wird durch das nächste Alt+Klick natürlich wieder das oberste Objekt markiert.

[Wenn Sie unter Linux arbeiten, dann könnte es sein, dass Alt+Klick nicht korrekt funktioniert und stattdessen z.B. das ganze Inkscape-Fenster verschiebt. Dies passiert, wenn Ihr Fenstermanager Alt+Klick für eine andere Aktion reserviert hat. Sie können in diesem Fall im Einstellungsdialog für Ihren Fenstermanager das Fensterverhalten anders einstellen, indem Sie die Aktion für diese Tastenkombination abschalten, oder sie auf die Meta-Taste (meist gleichbedeutend mit der Windows-Taste) umstellen. Dies erlaubt es Inkscape und anderen Anwendungen, die Alt-Taste frei zu verwenden.]

Das ist zwar schön, aber was kann man mit einem markierten und verdeckten Objekt anfangen? Man kann es durch Tastaturbefehle verändern, und man kann die Anfasser benutzen. Aber beim Versuch, das Objekt selbst mit der Maus zu verschieben, wird automatisch wieder das oberste Objekt markiert. (So funktioniert »Klicken und Ziehen« nunmal – es wählt das (oberste) Objekt unter dem Mauszeiger, dann verschiebt es das gewählte Objekt). Um Inkscape mitzuteilen, das man das gerade gewählte Objekt verschieben will, und nicht etwa ein anderes auswählen möchte, benutzt man Alt+Ziehen. Das verschiebt das aktuell markierte Objekt, egal wo man mit der Maus hinklickt.

Üben Sie Alt+Klick und Alt+Ziehen an den zwei braunen Objekten unter dem transparent-grünen Rechteck:

An example image

Ähnliche Objekte auswählen

Inkscape kann Objekte auswählen, die dem aktuell gewählten Objekt ähneln. Wenn man z.B. alle blauen Quadrate unten auswählen möchte, kann man einfach eines davon auswählen, und dann über das Menü Bearbeiten > Das Gleiche auswählen > Füllfarbe verwenden. Alle Objekte mit derselben blauen Füllfarbe sind nun ausgewählt.

An example image

Man kann ähnliche Objekte nicht nur nach deren Füllfarbe, sondern auch nach Konturfarbe, Konturstil, Füllung und Kontur zusammen und nach Objekttyp auswählen.

Schlusswort

Dies ist das Ende des Grundlagen-Tutorials. Das waren längst noch nicht alle Funktionen in Inkscape, aber mit den hier vermittelten Techniken können Sie schon einfache, aber nützliche Grafiken erstellen. Um kompliziertere Techniken zu erlernen, schauen Sie sich das Tutorial »Inkscape: Fortgeschrittene Benutzung« und die anderen Tutorials in Hilfe > Einführungen an.