このチュートリアルは、作品制作を助け効率化を図るいくつかの「隠し機能」やユーザーが見つけたさまざまなヒントやコツを紹介しています。

タイルクローンを使った放射状の配置

直角のグリッドやパターンは タイルクローン で簡単に作成できます。では、共通の中心から回転させる 放射状 の配置とかはどうでしょう? それもできます!

作りたい放射状パターンが、3、4、6、8、あるいは 12 の要素だけでいいなら、対称化の P3、P31M、P3M1、P4、P4M、P6、あるいは P6M を試してみてください。これは雪片などを作成するのに適しています。しかし、もっと汎用的なやり方だと次のようになります。

対称化の P1 (シンプル移動) を選び、シフト タブで 行ごと/垂直シフト および 列ごと/水平シフト をそれぞれ -100% に設定し、移動を平衡させます (訳注: 「タイルを考慮しない」を選んでもできます)。これですべてのクローンはオリジナルの上に正確に積み重なります。あとは 回転 タブで列ごとの回転角度を設定し、行が 1、列が複数になるようにして作成します。例として、以下に水平線、列数 30、回転角度 6°で作成したパターンを示します。

An example image

これを時計の目盛り板のようにするには、切り抜くか、シンプルに白い円で中心部を覆い隠します (クローン上でブーリアン演算を行うには、まずこれらのリンクを解除してください)。

行と列の両方を使うことによって、もっとおもしろい効果を作り出せます。ここに挙げたパターンは、列数 10、行数 8、行ごとの回転角度 2°、列ごとの回転角度 18°で作成したものです。ここでの各線のグループが「列」であり、グループはそれぞれ 18°ずつ離れています。各列内では、個々の線は 2°ずつ離れています:

An example image

上の例では線は中心から回転しています。しかし、中心をシェイプの外に置きたい時はどうしたらよいでしょう? そのシェイプを覆うように、中心を置きたいところにした見えない矩形 (フィルなし、ストロークなし) を作成し、シェイプと矩形をグループ化し、そのグループ上で タイルクローン を使用します。これは、拡大縮小、回転、そしておそらく不透明度もランダム化することでナイスな「爆発」あるいは「星形」にすることができる方法です:

An example image

スライス (領域を複数の矩形に分けてエクスポート) するには

新しくレイヤーを作成し、そのレイヤーにイメージの一部を覆うように見えない矩形を作成します。ドキュメントの単位が px (デフォルト) になっていることを確認し、グリッドをオンにして px 単位数全体に渡るように矩形をそれぞれグリッドにスナップさせます。各矩形に覚えやすい ID を割り当て、それぞれをそれぞれのファイルへエクスポートします (ファイル > ビットマップにエクスポートShift+Ctrl+E〕)。矩形はそれらがエクスポートされたファイル名を覚えていますので、その後は矩形のいくつかは簡単に再エクスポートできます — エクスポートレイヤーに切り替え、Tab で (または ID で検索して) エクスポートしたいオブジェクトを選択し、ダイアログからエクスポートをクリックします。または、以下のような、すべての領域を各領域ごとにエクスポートするコマンドでシェルスクリプトやバッチファイルを書くこともできます:

inkscape -i area-id -t filename.svg

-t スイッチは記憶しているファイル名ヒントを使用することを意味し、その他の場合は -e スイッチでファイル名を指定できます。

非線形グラデーション

SVG バージョン 1.1 は非線形グラデーション (すなわち色の非線形変換) をサポートしていません。しかし、マルチストップ グラデーションによってエミュレートすることができます。

まず、シンプルな 2 停止点のグラデーションを作成します。グラデーションエディターを開き (グラデーションツールでグラデーションハンドルをダブルクリック)、中間に新しい色フェーズを追加します (すこしドラッグしてください)。さらに色フェーズを追加し、それらもドラッグすることでグラデーションは滑らかになります。そしてさらに色フェーズを追加すれば、よりなめらかなグラデーションができあがります。以下は最初の白と黒の 2 停止点のみのグラデーションです:

An example image

そして以下はさまざまな「非線形」マルチストップグラデーションです (グラデーションエディターで調べてみてください)。

An example image

一風変わった放射状グラデーション

放射状グラデーションは対称性を持ちません。グラデーションツールで、楕円グラデーションの中心ハンドルを Shift キーを押しながらドラッグすると、×字形のグラデーションの焦点ハンドルが中心を離れて移動します。もし焦点を中心と同じ位置に戻したい場合は、中心ハンドル付近にドラッグすれば中心にスナップされます。

An example image

ページ中央への配置

オブジェクトやグループなどをページの中心あるいは端に配置するには、それを選択し、「整列と配置」ダイアログ (Ctrl+Shift+A) で 基準:ページ にして行います。

ドキュメントのクリーンアップ

パレットにもはや使われていないたくさんのグラデーション、パターン、あるいはマーカー (正確に言えば、あなたが編集したもの) が残っていても、それは新しいオブジェクトに再利用することができます。しかし、ドキュメントにあわせて整理したければ、ファイルメニューの Def のバキューム コマンドを使ってください。これはそのドキュメントで使用されていないすべてのグラデーション、パターン、あるいはマーカーを削除し、ファイルサイズを小さくします。

XML エディターの隠し機能

XML エディター (Shift+Ctrl+X) では、外部のテキストエディターを使用せずに、ドキュメントをほとんどすべての面から変更できます。Inkscape は GUI から編集できるよりも多くの SVG 機能をサポートしていますが、XML エディターはこれらの機能を利用する一つの手段です (もしあなたが SVG についてご存知ならば)。

ルーラーの単位の変更

デフォルトテンプレートでは、ルーラーで使用される単位は px (「SVG ユーザー単位」、Inkscape では 0.8pt または 1/90 インチ) です。これは座標の表示や単位メニューの初期値に使われています (マウスポインタをルーラーの上に移動させると使用している単位がツールチップに表示されます)。これを変更するには、ドキュメントの設定 (Ctrl+Shift+D) を開き、ページ タブの デフォルト単位 を変更します。

スタンプ

オブジェクトの複製を素早く作成するには、スタンプ 機能を使います。オブジェクトをドラッグ (または拡大縮小や回転) し、マウスボタンを押している間に スペース キーを押します。その時点でのオブジェクトが「スタンプ」として残ります。好きなだけこれを繰り返せます。

ペンツールの裏技

ペン (ベジエ) ツールで描画中の線を完了させるには以下のオプションがあります:

パスが完了していない間 (描画した線が緑色、現在のセグメントは赤色) は、オブジェクトはまだドキュメント上に存在していないことに注意してください。従って、それをキャンセルするには、元に戻す のではなく、Esc キー (パス全体をキャンセル) または Backspace キー (未完了のパスの最後のセグメントのみ削除) を使用します。

既存のパスに新規にサブパスを追加するには、パスを選択し Shift キーを押しながら任意のポイントを描画してください。しかし、既存のパスを伸ばしたいだけならば、Shift を押す必要はありません。単に選択したパスの終点から描画を開始してください。

Unicode 値の入力

テキストツールでは、Ctrl+U を押すことで Unicode と通常モードを切り替えます。Unicode モードでは 4 個の 16 進数のグループを入力することで Unicode 1 文字になりますので、(あなたがそれらの Unicode を知っており、フォントがサポートしている限り) 任意の記号を入力する事ができます。Unicode 入力を終了するには Enter キーを押します。例えば、Ctrl+U 2 0 1 4 Enter で emダッシュ(—) が挿入されます。何も入力せずに Unicode を抜けるには Esc キーを押します。

アイコン描画のためのグリッドの使用

24×24 ピクセルのアイコンを作成したい場合は、24×24 px のキャンバスを作成 (ドキュメントの設定) し、グリッドを 0.5 px (48×48 のグリッド線に設定) します。フィルのオブジェクトを偶数のグリッド線に、ストロークのオブジェクトを奇数のグリッド線に配置したら、それをデフォルトの 90dpi (1 px は 1 ビットマップピクセルになります) でエクスポートします。するとアンチエイリアスのかかっていないビットマップ画像が出来上がります。

オブジェクトの回転

選択ツールの時に、オブジェクトをクリックすると、拡大縮小の矢印が表示され、そのオブジェクト上で再度クリックすると回転およびシフトの矢印が表示されます。角の矢印をクリックおよびドラッグすると、オブジェクトはその中心を軸 (+印が表示されます) として回転します。Shift キーを押すと、対角を軸として回転します。回転軸はドラッグで好きな位置に置くことができます。

また、キーボードから [ および ] キーを押すと 15°ずつ回転し、Ctrl+[ および Ctrl+] キーを押すと90°ずつ回転します。Alt キーを押しながらだと、ピクセルサイズ単位のゆっくりとした回転になります。

影を落とす

(訳注: Inkscape 0.47 以降では「フィルタ」→「光と影」→「影を落とす」でできます) Inkscape はガウスぼかし SVG フィルタをサポートしていますので、オブジェクトにぼかした影を落とすのも簡単にできます。オブジェクトを選択し、Ctrl+D で複製を作成し、PgDown でオリジナルオブジェクトの真下に置き、それをオリジナルオブジェクトの斜め下にずらします。フィル/ストロークダイアログを開いて「ぼかし」値を変更します。

パス上にテキストを置く

曲線に沿ってテキストを配置するには、テキストと曲線を一緒に選択し、「テキスト」メニューから テキストをパス上に配置 を選びます。テキストはパスの先頭からパスに沿って表示されます。一般に、テキストを沿わせるにはそれ用にパスを作成するのが最適です。

オリジナルを選択する

パス上に配置したテキスト、リンクオフセット、あるいはクローンがある場合、場合によってはそれらのもととなるオブジェクト/パスを探すのが難しくなるかもしれません。なぜなら、それは直下にあるとか、見えなくしている、あるいはロックされているかもしれないからです。マジックキー Shift+D がそれを助けてくれます。テキスト、リンクオフセット、あるいはクローンを選択し、Shift+D を押すと対応するパス、オフセットソース、あるいはクローンオリジナルが選択されます。

画面の外に出てしまったウィンドウの回復

ドキュメントを解像度のやディスプレイの数が異なるシステムに移動した場合、Inkscape がウィンドウの位置を記憶しているために、画面の外にウィンドウが表示されてしまうかもしれません。その時は (タスクバーなどを使って) ウィンドウを全画面化して保存し、再び開いてください。Inkscape の設定ウィンドウ タブでウィンドウの位置とサイズの保存をしないように設定すれば、この問題を回避できます。

透明、グラデーション、そして PostScript エクスポート

PostScript や EPS 形式は透明度をサポートしていません。なので、それを決して PS/EPS にエクスポートしないでください。均一な透明データが単一色を覆っている場合は簡単に解決できます。透明オブジェクトを選択し、スポイトツールに切り替え (F7)、「採取」(不透明度の採取モード) をオフにして、同じオブジェクトをクリックします。表示色が採取され、オブジェクトの背後に割り当てられますが、この時点で透明度は存在しません。すべての透明オブジェクトでこれを繰り返します。透明オブジェクトがいくつかの色の領域を覆っている場合、それに応じて透明オブジェクトを分割し、それぞれにこの手順を適用します。

グラデーションの PS/EPS へのエクスポートはテキスト (テキストがパスに変換されている場合を除く) やストロークの塗りに対しては機能しません。また、透明度は PS/EPS へのエクスポートでは失われるので、例えば不透明な青から 透明な青へのグラデーションなどは使用できません。次善の策として、グラデーションを不透明な青から不透明な背景色に置き換えてください。