Follow us on:

Home

Inkscape tutorial: Básico

Este tutorial demonstra o funcionamento básico do Inkscape. É um documento regular que você pode ver, editar, copiar dele, ou gravar.

O tutorial Básico aborda a navegação na lousa (ou canvas, em inglês), administração de documentos, funcionamento básico das ferramentas de forma, técnicas de seleção, transformação de objetos com a ferramenta de seleção, agrupamento, configuração de preencimento e traço, alinhamento, e superposição (ordem-z). Para tópicos mais avançados, verifique os outros tutoriais no menu Ajuda.

Navegando pela tela

Existem muitas maneiras de navegar (rolar) a lousa do documento. Tente as teclas Ctrl+setas para rolar pelo teclado. (Tente isto agora para rolar este documento para baixo.) Você pode também arrastar a lousa com o botão do meio do mouse. É possível também usar as barras de rolagem (pressione Ctrl+B para mostrar ou escondê-las). A roda do seu mouse também funciona para rolar verticalmente; pressione Shift junto com a roda para rolar horizontalmente.

Aumentantdo e diminuindo o Zoom

O jeito mais fácil de dar um zoom é pressionando as teclas - e + (ou =). Você pode também usar Ctrl+clique com o botão do meio ou Ctrl+clique com o botão direito para aumentar o zoom, Shift+clique com o botão do meio ou Shift+clique com o botão direito para diminuir o zoom, ou gire a roda do mouse com Ctrl. Ainda, você pode clicar no campo do zoom (no canto esquerdo inferior da janela do documento), digitar um valor do zoom preciso em %, e pressionar Enter. Também temos a ferramenta Ampliar ou reduzir nível de Zoom (na barra Caixa de Ferramentas à esquerda) que te permite dar um zoom em uma área arrastando o cursor sobre ela.

O Inkscape também mantém um histórico dos zoom's que você usou nesta sessão de trabalho. Pressione a tecla ` para retornar ao zoom anterior, ou Shift+` para ir ao seguinte.

Ferramentas do Inkscape

A barra de ferramentas vertical à esquerda mostra as ferramentas de desenho e edição do Inkscape. Na parte superior da janela, abaixo do menu, localiza-se a Barra de Comandos com botões de comando gerais e a barra Controles de Ferramenta com controles que são específicos para cada ferramenta. A Barra de Estado na parte inferior da janela mostra dicas úteis e mensagens enquanto você trabalha.

Muitas operações estão disponíveis através de teclas de atalho. Abra Ajuda > Teclas e Atalhos para ver a referência completa.

Criando e administrando documentos

Para criar um documento novo vazio, use Arquivo > Novo ou pressione Ctrl+N. Para abrir um documento SVG existente, use Arquivo > Abrir (Ctrl+O). Para salvar, use Arquivo > Salvar (Ctrl+S), ou Salvar Como (Shift+Ctrl+S) para salvar com um nome novo. (O Inkscape pode ser instável, logo lembre de salvar freqüentemente!)

O Inkscape usa o formato SVG (Scalable Vector Graphics) para seus arquivos. O SVG é um padrão aberto vastamente suportado por softwares gráficos. Arquivos SVG são baseados em XML e podem ser editados com qualquer editor de textos ou de XML (isto é, além do editor do Inkscape). Além de SVG, o Inkscape pode importar e exportar vários outros formatos (EPS, PNG).

Inkscape opens a separate document window for each document. You can navigate among them using your window manager (e.g. by Alt+Tab), or you can use the Inkscape shortcut, Ctrl+Tab, which will cycle through all open document windows. (Create a new document now and switch between it and this document for practice.) Note: Inkscape treats these windows like tabs in a web browser, this means the Ctrl+Tab shortcut only works with documents running in the same process. If you open multiple files from a file browser or launch more than one Inkscape process from an icon it will not work.

Criando formas

Hora para algumas formais legais! Clique na ferramenta Retângulo na barra Caixa de Ferramentas (ou pressione F4) e clique e arraste, em um novo documento vazio ou aqui mesmo:

An example image

As you can see, default rectangles come up blue, with a black stroke (outline), and fully opaque. We'll see how to change that below. With other tools, you can also create ellipses, stars, and spirals:

An example image

Estas ferramentas são conhecidas coletivamente como ferramentas de forma. Cada forma criada mostra uma ou mais alças em forma de diamante; tente arrastá-las para ver como a forma responde. O painel Controles de Ferramenta para uma ferramenta de forma é outra maneira de modificar uma forma; estes controles afetam as formas atualmente selecionadas (ou seja, aquelas que mostram as alças) e configuram o padrão que será aplicado a formas recém criadas.

Para desfazer sua última ação, pressione Ctrl+Z. (Ou, se você mudar de idéia de novo, você pode refazer a ação desfeita com Shift+Ctrl+Z.)

Movendo, redimensionando, girando

A ferramenta do Inkscape mais frequentemente usada é a ferramenta deSeleção (ou seletor). Clique no botão mais alto (em forma de cursor) na barra Caixa de Ferramentas, ou pressione F1 ou Barra de Espaço. Agora você pode selecionar qualquer objeto na tela. Clique no retângulo abaixo.

An example image

Você verá oito alças em forma de seta aparecerem ao redor do objeto. Agora você pode:

Agora clique no retângulo novamente. As alças mudam. Agora você pode:

Com o seletor, você pode também usar os campos numéricos na barra Controles de Ferramenta (acima da lousa) para configurar valores exatos para as coordenadas (X e Y) e tamanho (W e H) da seleção.

Transformando com as teclas

Uma das características do Inkscape que o diferencia da maioria dos outros editores vetoriais é sua ênfase na acessibilidade através do teclado. Dificilmente existe algum comando ou ação que seja impossível de realizar a partir do teclado, e transformar objetos não é exceção.

You can use the keyboard to move (arrow keys), scale (< and > keys), and rotate ([ and ] keys) objects. Default moves and scales are by 2 px; with Shift, you move by 10 times that. Ctrl+> and Ctrl+< scale up or down to 200% or 50% of the original, respectively. Default rotates are by 15 degrees; with Ctrl, you rotate by 90 degrees.

Entretanto, talvez a mais útil seja a transformação em escala de pixel, executada usando Alt com as teclas de transformação. Por exemplo, Alt+setas moverá a seleção em 1 pixel no zoom atual (ou seja em 1 pixel de tela, não confunda com a unidade px que é uma unidade de comprimento do SVG independente do zoom). Isto significa que se você aumentar o zoom, ao pressionar Alt+setas resultará em um movimento absoluto menor que ainda se parecerá com um movimento suave de um pixel na sua tela. Assim é possível posicionar os objetos com precisão arbitrária simplesmente aumentando ou diminuindo o zoom como desejado.

De maneira semelhante, Alt+> e Alt+< modificam as dimensões do objeto de modo que seu tamanho visível altere em um pixel de tela, e Alt+[ e Alt+] giram-no de modo que o ponto mais longe do centro se mova em um pixel de tela.

Nota: usuários do Linux podem não obter os resultados esperados com a combinação Alt+setas e algumas outras combinações se seus gerenciadores de janelas executam estes eventos de tecla antes do Inkscape. Uma solução seria modificar a configuração do gerenciador de janelas.

Seleções Múltiplas

Você pode selecionar qualquer quantidade de objetos simultaneamente clicando sobre juntamente com Shift. Ainda mais, você pode arrastar o cursor em volta dos objetos que deseja selecionar; isto se chama seleção elástica. (O seletor cria seleção elástica quando se arrasta a partir de um espaço vazio; entretanto, se você pressionar Shift antes de começar a arrastar, o Inkscape sempre criará a seleção elástica.) Pratique selecionando todas as três formas abaixo:

An example image

Agora, use a seleção elástica (pelo arrasto ou Shift+arrasto) para selecionar as duas elipses mas não o retângulo:

An example image

Cada objeto individual dentro de uma seleção mostra uma marca de seleção — por padrão, uma caixa retangular pontilhada. Estas marcas facilitam a visualização imediata do que está e não está selecionado. Por exemplo, se você selecionar tanto as duas elipses quanto o retângulo, sem as marcas seria difícil adivinhar se as elipses estão ou não selecionadas.

Shift+Clique sobre um objeto selecionado o exclui da seleção. Selecione todos os três objetos acima, depois use Shift+Clique para excluir ambas as elipses da seleção deixando apenas o retângulo selecionado.

Pressionando Esc desfaz a selecão de qualquer objeto selecionado. Ctrl+A seleciona todos os objetos na camada atual (se você não criou camadas, isto é o mesmo que todos os objetos no documento).

Agrupando

Vários objetos podem ser combinados em um grupo. Um grupo se comporta como um objeto único quando você arrasta ou transforma-o. Abaixo, os três objetos à esquerda estão independentes; os mesmo três objetos à direita estão agrupados. Tente arrastar o grupo.

An example image

Para criar um grupo, selecione um ou mais objetos e pressione Ctrl+G. Para desagrupar um ou mais grupos, selecione-os e pressione Ctrl+U. Os mesmo grupos podem ser agrupados, como qualquer outro objeto; tais grupos recursivos podem por-se em profundidades arbitrárias. Entretanto, Ctrl+U apenas desagrupa o nível mais alto de agrupamento em uma seleção; você vai precisar pressionar Ctrl+U repetidamente se você quiser desagrupar completamente um grupo "profundo" dentro de outro grupo.

Você não tem que necessariamente desagrupar, a não ser que você queira editar um objeto dentro de um grupo. Apenas Ctrl+Clique sobre o objeto e este será selecionado e editável sozinho, ou Shift+Ctrl+Clique sobre vários objetos (dentro ou fora de qualquer grupo) para seleção múltipla independente do agrupamento. Tente mover ou transformar as formas individualmente no grupo (acima à direita) sem desagrupá-lo, depois desfaça a seleção e selecione o grupo normalmente para ver que ele ainda permanece agrupado.

Preenchimento e traço

Muitas das funções do Inkscape estão disponíveis através das caixas de diálogos. Provavelmente a maneira mais simples de pintar um objeto de alguma cor é abrir a caixa de diálogos Modelos de Cores do menu Objetos, selecionar um objeto, e clicar em um modelo de cor para pintá-lo (modifica sua cor de preenchimento).

Mais poderosa é a caixa de diálogos Preenchimento e Traço (Shift+Ctrl+F). Selecione a forma abaixo e abra a caixa de diálogos Preenchimento e Traço.

An example image

Você verá que a caixa tem três abas: Preencher, Pintura de traço e Estilo de traço. A aba Preencher te permite editar o preenchimento (interior) do(s) objeto(s) selecionado(s). Usando os botões logo abaixo da aba, você pode selecionar tipos de preenchimento, incluindo nenhum preenchimento (o botão com o X), preenchimento de cor lisa, bem como gradientes lineares ou radiais. Para a forma acima, o botão de cor lisa será ativado.

Mais abaixo, você vê uma coleção de seletores de cores, cada um em sua própria aba: RGB, CMYK, HSL, e Roda. Talvez o mais prático seja o seletor Roda, onde você pode girar o triângulo para escolhar uma cor na roda, e depois selecionar um tom dessa cor dentro do triângulo. Todos os seletores de cor contém um deslizador para configurar o alfa (transparência) do(s) objeto(s) selecionado(s) .

Sempre que você seleciona um objeto, o seletor de cores é atualizado para mostrar seu preenchimento e traço atual (quando múltiplos objetos são selecionados, a caixa de diálogos mostra sua cor média). Brinque com estes exemplos ou crie os seus próprios:

An example image

Usando a aba Pintura de traço, você pode remover o traço (contorno) do objeto, ou atribuir qualquer cor ou transparência:

An example image

A última aba, Estilo de traço, te permite configurar a largura e outros parâmetros do traço:

An example image

Finalmente, no lugar de cor lisa, você pode usar gradientes para preenchimentos e/ou traços:

An example image

Quando você muda de cor lisa para gradiente, o gradiente recém criado usará a cor lisa anterior, variando de opaca a transparente. Mude para a ferramenta Gradiente (Ctrl+F1) para arrastar as alças do gradiente — os controles conectados por linhas que definem a direção e extensão do gradiente. Quando qualquer alça do gradiente é selecionada (destacada em azul), a caixa de diálogos Preenchimento e Traço configura a cor dessa alça em vez da cor do objeto inteiro selecionado.

Uma outra maneira prática de mudar a cor de um objeto é através da ferramenta Conta-gotas (F7). Apenas clique em qualquer lugar do desenho com essa ferramenta, e a cor capturada será atribuída ao preenchimento do objeto selecionado (Shift+clique atribui a cor do traço).

Duplicação, alinhamento, distribuição

Uma das operações mais comuns é a de duplicar um objeto (Ctrl+D). O objeto duplicado é colocado exatamente acima do original e selecionado, assim você pode arrastá-lo com o mouse ou pelas setas do teclado. Para praticar, tente preencher a linha com cópias deste quadrado preto:

An example image

São boas as chances de que suas cópias sejam posicionadas mais ou menos aleatoriamente. Aqui é onde a caixa de diálogos Alinhar e Distribuir se mostra útil (Ctrl+Shift+A). Selecione todos os quadrados (Shift+clique ou faça uma seleção elástica), abra a caixa e pressione o botão "Centralizar horizontalmente", depois o botão "Distribuir a distância horizontal igualmente entre os objetos" (leia as mensagens que aparecem quando se paira o mouse sobre os botões). Agora os objetos estão alinhados caprichosamente e distribuídos de maneira equidistante. Aqui estão outros exemplos de alinhamento e distribuição:

An example image

Ordem-Z (ou superposição)

O termo ordem-z se refere a ordem de empilhamento de objetos em um desenho, ou seja, a que objetos estão no topo e obscurecem os outros. Os dois comandos no menu Objeto, Levantar no Topo (tecla Home) e Abaixar para o Fundo (tecla End), moverá os objetos selecionados para a parte mais alta ou mais baixa da superposição dos objetos. Dois outros comandos, Levantar (PgUp) e Abaixar (PgDn), abaixará ou levantará a seleção em apenas um passo, ou seja, move para cima um objeto não selecionado na superposição (apenas objetos que sobrepõem a seleção contam; se nada sobrepõe a seleção, Levantar e Abaixar move-a completamente para cima ou para baixo respectivamente).

Pratique usando estes comandos revertendo a ordem-z dos objetos abaixo, de modo que a elipse mais à esquerda fique no topo e a elipse mais à direita fique no fundo:

An example image

Um tecla de atalho de seleção muito útil é Tab. Se nada está selecionado, ela seleciona o objeto que está mais ao fundo; senão ela seleciona o objeto acima do(s) objeto(s) selecionado(s) na ordem-z. Shift+Tab funciona de maneira contrária, começando a partir do objeto situado no topo e procedendo para baixo. Uma vez que os objetos que você cria são adicionados ao topo da pilha, pressionar Shift+Tab com nada selecionado, o objeto que você criou por último será selecionado. Pratique as teclas Tab e Shift+Tab na pilha de elipses acima.

Selecionando o objeto de baixo e arrastando

O que fazer se o objeto que você precisa está escondido atrás de outro objeto? Você consegue ainda ver o objeto do fundo se o que está no topo for (parcialmente) transparente, mas clicando sobre ele, o objeto do topo que será selecionado, não o que você precisa.

Para isto é que serve Alt+clique. O primeiro Alt+clique seleciona o objeto do topo como um simples clique normal. No entanto, o próximo Alt+clique no mesmo ponto selecionará o objeto abaixo do que está no topo; o pŕoximo, o objeto mais abaixo, etc. Assim, vários Alt+cliques sucessivos navegará, de cima a baixo, através de toda a pilha de objetos na ordem-z no ponto do clique. Quanto o objeto do fundo é atingido, o próximo Alt+clique selecionará, naturalmente, o objeto do topo novamente.

[If you are on Linux, you might find that Alt+click does not work properly. Instead, it might be moving the whole Inkscape window. This is because your window manager has reserved Alt+click for a different action. The way to fix this is to find the Window Behavior configuration for your window manager, and either turn it off, or map it to use the Meta key (aka Windows key), so Inkscape and other applications may use the Alt key freely.]

Isto é bom, mas uma vez que você selecionou um objeto que está coberto por outro, o que você pode fazer com ele? Usar as teclas para transformá-lo, e arrastar as alças de seleção. No entanto, ao arrastar o próprio objeto, a seleção do objeto do topo será retomada (para isto é que clicar-e-arrastar foi projetado — seleciona o objeto (do topo) sob o cursor primeiro, depois arrasta a seleção). Para dizer ao Inkscape para arrastar o que está selecionado agora sem selecionar mais nada, use Alt+arrastar. Isto moverá a seleção atual não importa de onde você arraste seu mouse.

Pratique Alt+clique e Alt+arrastar nas duas formas marrons que estão abaixo do retângulo transparente verde:

An example image

Conclusão

Isto conclui o tutorial Básico. Tem muito mais que isso no Inkscape, mas com as técnicas descritas aqui, você já será capaz de criar gráficos simples porém úteis. Para coisas mais avançadas, leia o tutorial Avançado e os outros em Ajuda > Tutoriais.