Follow us on:

Home

Inkscape tutorial: Podstawy

Ten poradnik przedstawia podstawowe zagadnienia dotyczące pracy z Inkscape'em. Jest to standardowy dokument Inkscape'a i można go przeglądać, edytować, kopiować czy zapisywać.

Omawia on nawigację w obszarze roboczym, zarządzanie dokumentami, podstawowe narzędzia kształtów, techniki zaznaczania, przekształcanie obiektów za pomocą wskaźnika, grupowanie, ustawianie wypełniania i konturu, wyrównanie i kolejności. Aby zapoznać się z bardziej zaawansowanymi tematami, z menu „Pomoc” wybierz interesujące cię zagadnienie.

Przesuwanie obszaru roboczego

Jest wiele sposobów przesuwania (przewijania) obszaru roboczego dokumentu. Najbardziej znany to przewijanie obszaru roboczego za pomocą pasków przewijania. Można je ukryć/wyświetlić używając skrótu [ Ctrl+B ]. Innym sposobem jest przewijanie za pomocą klawiatury przy użyciu klawiszy [ Ctrl+strzałki ]. Można to sprawdzić wykonując teraz próbę przewinięcia tego dokumentu. Można również przesuwać obszar roboczy za pomocą środkowego przycisku myszy. Wygodnym sposobem przewijania obszaru roboczego jest przewijanie [ kółkiem ] myszy ze wciśniętym klawiszem [ Shift ] – przesuwanie w poziomie lub, jeśli w opcjach zaznaczono pprzybliżanie obszaru roboczego za pomocą kółka myszy, [ Ctrl ] – przesuwanie w pionie.

Przybliżanie/Oddalanie

Łatwą metodą przybliżania/oddalania (zoom) jest użycie klawiszy [ - ], [ + ] i [ = ]. Można także używać skrótu [ Ctrl+kliknięcie ] lub [ Ctrl+kliknięcie prawym przyciskiem myszy ] do przybliżania oraz [ Shift+kliknięcie środkowym przyciskiem myszy ], lub [ Shift+kliknięcie prawym przyciskiem myszy ] do oddalania. Wygodnym sposobem przybliżania/oddalania jest użycie kółka myszy ze wciśniętym klawiszem [ Ctrl ]. Można także w polu pokazującym aktualną wartość przybliżenia, znajdującym się w dolnym prawym rogu, wprowadzić żądaną wartość skalowania i nacisnąć klawisz [ Enter ]. W przyborniku znajduje się także narzędzie „Przybliżenie”, które można używać na kilka sposobów – wykonując ciągnięcie myszą wokół elementu, który chcemy przybliżyć/oddalić, lub klikając lewym lub prawym przyciskiem myszy.

Inkscape przechowuje historię używanych w danej sesji poziomów skalowania obszaru roboczego. Wystarczy nacisnąć klawisz [ ` ], aby przywrócić poprzednią skalę lub [ Shift+` ], aby przejść do przodu.

Narzędzia Inkscape'a

Pionowy pasek znajdujący się po lewej stronie okna to „Przybornik”, zawierający narzędzia rysowania i edycji. W górnej części okna, poniżej menu głównego, znajduje się pasek poleceń, na którym umieszczone są przyciski realizujące główne polecenia programu. Poniżej tego paska znajduje się pasek kontrolek narzędziowych, zawierający elementy kontrolne przypisane narzędziu aktualnie wybranemu z przybornika. Na pasku stanu, położonym na dole okna, są wyświetlane użyteczne podpowiedzi dotyczące aktualnie wykonywanej czynności.

Wiele operacji jest dostępnych za pomocą skrótów klawiaturowych. Przejdź do menu Pomoc » Opis skrótów, aby zobaczyć ich listę i opisy.

Tworzenie dokumentów i zarządzanie nimi

Aby utworzyć nowy, pusty dokument, należy z menu Plik » Nowy wybrać odpowiedni typ dokumentu lub nacisnąć kombinację klawiszy [ Ctrl+N ]. Aby otworzyć istniejący dokument SVG, należy z menu „Plik” wybrać element „Otwórz…” lub nacisnąć kombinację klawiszy [ Ctrl+O ]. Aby zapisać dokument, należy posłużyć się menu „Plik » Zapisz” lub kombinacją klawiszy [ Ctrl+S ]. Zapis pliku z nową nazwą realizuje się za pomocą polecenia „Zapisz jako…” dostępnego w menu „Plik” lub kombinacji klawiszy [ Shift+Ctrl+S ]. Inkscape jest nadal w fazie rozwojowej i może być niestabilny, zatem zapisuj swoją pracę dość często!

Inkscape do zapisu swoich plików używa formatu SVG (Scalable Vector Graphics). SVG jest otwartym standardem szeroko wspieranym przez programy do obróbki grafiki. Pliki SVG są oparte na języku XML i mogą być edytowane za pomocą dowolnego edytora tego języka. Edytor taki posiada także Inkscape. Oprócz formatu SVG, Inkscape może importować i eksportować pliki w innych formatach (EPS, PNG).

Inkscape otwiera oddzielne okno dla każdego dokumentu. Można przemieszczać się pomiędzy nimi używając swojego menedżera okien np. za pomocą skrótu [ Alt+Tab ] lub skrótu Inkscape'a [ Ctrl+Tab ], który pozwala na przemieszczanie się pomiędzy wszystkimi otwartymi oknami. Utwórz teraz nowy dokument i wypróbuj opisane wcześniej sposoby. Informacja: Inkscape traktuje te okna, jak karty w przeglądarce. Oznacza to, że skrót klawiszowy Ctrl+Tab działa tylko z dokumentami uruchomionymi w tym samym procesie. Jeśli zostanie otwarte wiele plików z poziomu przeglądarki plików lub uruchomiony więcej niż jeden proces Inkscape'a z ikony, skrót ten nie będzie działał.

Tworzenie kształtów

Nadszedł czas na kilka ćwiczeń praktycznych! Wybierz z przybornika narzędzie „Prostokąt” lub naciśnij klawisz [ F4 ]. Teraz możesz przystąpić do tworzenia prostokątów. Wykonaj myszą kilka ciągnięć w obrębie obszaru roboczego nowego dokumentu lub bezpośrednio tutaj:

An example image

As you can see, default rectangles come up blue, with a black stroke (outline), and fully opaque. We'll see how to change that below. With other tools, you can also create ellipses, stars, and spirals:

An example image

Wszystkie te narzędzia są ogólnie zwane narzędziami kształtu. Na każdym utworzonym kształcie są widoczne w postaci malutkich rombów lub kwadracików uchwyty. Złap jeden z nich i wykonaj ciągnięcie – zobaczysz, jak zmienia się kształt. Z poziomu paska kontrolek, widocznego po zaznaczeniu kształtu, można udoskonalać kształt i określać jego domyślne parametry używane podczas tworzenia nowych elementów.

Aby wycofać ostatnią operację, należy użyć skrótu klawiaturowego [ Ctrl+Z ], a jeśli chce się przywrócić wycofaną operację, należy użyć skrótu [ Shift+Ctrl+Z ].

Przesuwanie, skalowanie, obracanie

Najczęściej używanym narzędziem jest „Wskaźnik”. Wybierz narzędzie wskaźnika (przycisk ze strzałką) znajdujące się na samej górze przybornika lub naciśnij klawisz [ F1 ] albo klawisz spacji. Teraz możesz zaznaczyć każdy obiekt znajdujący się w obszarze roboczym. Kliknij znajdujący się poniżej prostokąt.

An example image

Wokół prostokąta wyświetliło się osiem uchwytów w postaci strzałek. Teraz możesz:

Kliknij ponownie na prostokącie. Uchwyty zmieniły swój wygląd. Teraz możesz:

Pracując w trybie wskaźnika, do określenia współrzędnych X i Y oraz wielkości (Szer. i Wys.) zaznaczonego obiektu można także używać pól numerycznych znajdujących się na pasku kontrolek narzędzia.

Przekształcanie za pomocą klawiszy

Twórcy Inkscape'a położyli szczególny nacisk na dostępność funkcji poprzez klawiaturę. Jest to cecha wyróżniającą go spośród większości programów do grafiki wektorowej. Prawie każdą czynność można wykonać za pomocą klawiatury włącznie z przekształceniami obiektów.

Za pomocą klawiatury można przesuwać – [ klawisze strzałek ], skalować – klawisze [ < ] i [ > ] oraz obracać obiekty – klawisze [ [ ] i [ ] ]. Domyślnie przesunięcie, obrót lub skalowanie obiektu następuje o 2 piksele. Przytrzymując klawisz [ Shift ] operacje te można zwielokrotnić 10 razy. Używając skrótu [ Ctrl+> ] i [ Ctrl+< ] obiekt można powiększać lub pomniejszać odpowiednio o 200, lub 50%. Domyślnie obrót obiektu jest realizowany o kąt 15°, z przytrzymanym klawiszem [ Ctrl ] obiekt jest obracany o kąt 90°.

Jedną z najbardziej użytecznych jest funkcja przekształcenia o wielkość 1 piksela, wywoływana za pomocą kombinacji [ Alt ] z jednym z klawiszy przekształceń. Na przykład kombinacja klawiszy [ Alt+strzałki ] przesuwa zaznaczenie o 1 piksel w aktualnym powiększeniu tj. o 1 piksel ekranowy. Proszę nie mylić tej wartości z jednostką px, która jest jednostką długości formatu SVG niezależną od powiększenia. Oznacza to, że w czasie przybliżania obrazu kombinacja klawiszy [ Alt+strzałka ] spowoduje przesunięcie obrazu o mniej niż 1 piksel absolutnego przesunięcia, zatem obraz na ekranie będzie wyglądał tak jakby przesunięcie nastąpiło o 1 piksel. Dzięki temu możliwe jest dokładne pozycjonowanie obrazu za pomocą przybliżania i oddalania.

Podobnie kombinacja klawiszy [ Alt+> ] i [ Alt+< ] skaluje zaznaczony obiekt, zmieniając jego rozmiar o jeden piksel ekranowy. Natomiast kombinacja klawiszy [ Alt+[ ] oraz [ Alt+] ] obraca go tak, że jego najdalej położony od środka punkt jest przysuwany o jeden piksel ekranowy.

Informacja: W systemie Linux skrót klawiaturowy [ Alt+strzałka ] oraz kilka innych kombinacji może działać nieprawidłowo, jeśli przed instalacją Inkscape'a zostały one przydzielone innym aplikacjom/czynnościom. Rozwiązaniem tego problemu jest odpowiednia zmiana skrótów klawiaturowych w menedżerze okien.

Zaznaczanie wielu obiektów

Można zaznaczać dowolną liczbę obiektów klikając kolejne obiekty ze wciśniętym klawiszem [ Shift ]. Żądane obiekty można również zaznaczyć wykonując ciągnięcie myszą wokół tych obiektów. Ten sposób zaznaczania nazywa się zaznaczaniem elastycznym. Wskaźnik podczas ciągnięcia rozpoczętego w pustym miejscu tworzy wokół obiektów jak gdyby elastyczną gumkę, która opina zakreślone obiekty. Naciśnięcie klawisza [ Shift ] przed rozpoczęciem ciągnięcia zawsze utworzy zaznaczenie elastyczne, nawet jeśli ciągnięcie rozpoczęto na obiekcie. Sprawdź to w praktyce, zaznaczając wszystkie poniższe trzy kształty:

An example image

Teraz użyj zaznaczania elastycznego, aby zaznaczyć dwie elipsy, ale nie zaznaczać prostokąta:

An example image

Wokół każdego obiektu, wewnątrz zaznaczenia, wyświetlana jest ramka zaznaczenia. Domyślnie jest to prostokątna ramka utworzona za pomocą przerywanej linii. Dzięki temu można łatwo odróżnić obiekty zaznaczone i niezaznaczone. Na przykład, jeśli ramka zaznaczenia byłaby niewidoczna, trudno byłoby w poprzednio wykonywanym ćwiczeniu zorientować się, czy obie elipsy zostały zaznaczone.

Można w łatwy sposób wyłączyć z zaznaczenia dany obiekt, klikając go ze wciśniętym klawiszem [ Shift ]. Zaznacz wszystkie powyższe obiekty, a następnie za pomocą kombinacji [ Shift+kliknięcie ] wyłącz z zaznaczenia obie elipsy, pozostawiając zaznaczony prostokąt.

Naciśnięcie klawisza [ Esc ] powoduje zdjęcie znaczenia ze wszystkich obiektów. Użycie skrótu [ Ctrl+A ] powoduje zaznaczenie wszystkich obiektów na aktywnej warstwie. Jeśli nie utworzono warstw, skrót działa tak samo, jak zaznaczanie wszystkich elementów w dokumencie.

Grupowanie

Różne obiekty mogą zostać połączone w grupę. Grupa podczas przeciągania czy przekształcania zachowuje się tak jak pojedynczy obiekt. Poniższe, położone po lewej stronie trzy obiekty są niezależne. Te same obiekty po prawej stronie są zgrupowane. Spróbuj przeciągnąć grupę.

An example image

Aby utworzyć grupę, należy zaznaczyć kilka obiektów i użyć skrótu [ Ctrl+G ]. Aby rozdzielić jedną lub więcej grup, należy je zaznaczyć i nacisnąć klawisze [ Ctrl+U ]. Grupy mogą być grupowane tak jak pojedyncze obiekty. Takie rekurencyjne grupy można tworzyć na dowolną głębokość. W przypadku grup rekurencyjnych użycie skrótu [ Ctrl+U ] spowoduje rozdzielenie grup najwyższego poziomu w zaznaczeniu. Aby całkowicie rozdzielić grupy, trzeba użyć skrótu [ Ctrl+U ] wielokrotnie.

Jeśli chcesz edytować obiekt znajdujący się w grupie, nie musisz jej rozdzielać. Wystarczy nacisnąć klawisz [ Ctrl ] i kliknąć obiekt, który zamierzasz edytować. Obiekt zostanie zaznaczony i można wykonywać na nim żądane operacje. Aby zaznaczyć kilka obiektów niezależnie od grupowania, można użyć skrótu [ Shift+Ctrl ] i kliknąć różne obiekty wewnątrz i na zewnątrz grup. Spróbuj przesunąć lub przekształcić pojedyncze kształty znajdujące się powyżej, po prawej stronie bez rozdzielania grupy, a następnie odznacz i zaznacz grupę normalnie. Pomimo wykonania operacji wewnątrz grupy, obiekty są nadal zgrupowane.

Wypełnienie i kontur

Wiele funkcji Inkscape'a jest dostępnych poprzez okna dialogowe. Na przykład łatwym sposobem wypełnienia obiektu kolorem lub zmiany koloru wypełnienia jest otworzenie okna dialogowego „Przykładowe kolory” poprzez wybranie tego elementu z menu „Widok” lub naciśnięcie kombinacji klawiszy [ Shift+Ctrl+W ], zaznaczenie obiektu i wybranie próbki koloru z palety kolorów wyświetlonej w otwartym oknie dialogowym.

Bardzo użyteczne jest okno dialogowe „Wypełnienie i kontur” dostępne w menu „Obiekt” albo poprzez naciśnięcie kombinacji klawiszy [ Shift+Ctrl+F ]. Zaznacz poniższy kształt i otwórz okno „Wypełnienie i kontur”.

An example image

Nowo otwarte okno zawiera trzy karty: „Wypełnienie”, „Kontur” i „Styl konturu”. Karta „Wypełnienie” pozwala edytować wypełnienie (wnętrze) zaznaczonych obiektów. Przyciski znajdujące się na górze karty umożliwiają wybranie typu wypełnienia: wypełnienie kolorem jednolitym, gradientem liniowym lub radialnym oraz deseniem. Można również wyłączyć wypełnienie używając przycisku z oznaczeniem X. W przypadku powyższej elipsy zaznaczony będzie przycisk wypełnienia jednolitego.

Trochę niżej umiejscowione są palety kolorów, każda w osobnej karcie: RGB, CMYK, HSL i Koło. Bardzo wygodna w użyciu jest paleta kołowa, w której przesuwając biały wskaźnik znajdujący się na kole lub po prostu klikając żądany kolor można wybrać barwę, a następnie klikając lub przesuwając znajdujące się wewnątrz trójkąta kółeczko – odcień. Każda paleta kolorów zawiera suwak pozwalający ustawić kanał alfa – przezroczystość zaznaczonych obiektów.

Po zaznaczeniu obiektu paleta kolorów jest natychmiast aktualizowana, wyświetlając aktualne kolory wypełnienia i konturu. Jeśli zostało zaznaczone wiele obiektów z różnymi kolorami, w palecie wyświetlany jest uśredniony kolor. W ramach ćwiczenia przetestuj poniższe obiekty:

An example image

Używając narzędzi znajdujących się na karcie „Kontur” można usunąć kontur obiektu, przypisać mu dowolny kolor czy przezroczystość.

An example image

Ostatnia z kart – „Styl konturu” – pozwala określić szerokość i inne parametry konturu:

An example image

Możliwe jest wypełnienie obiektu gradientem zamiast wypełnienia jednolitego:

An example image

Podstawę nowo utworzonego wypełnienia gradientowego stanowi kolor wypełnienia jednolitego zdążający płynnie do przezroczystości. Aby zmienić kierunek i długość gradientu, wybierz z przybornika narzędzie „Gradient” [ Ctrl+F1 ] i ciągnąc uchwyty (kontrolki połączone linią) zmień te parametry. Jeśli chcesz zmienić kolory gradientu, zaznacz uchwyt gradientu znajdujący się w pobliżu koloru, który chcesz zmienić i w oknie dialogowym „Wypełnienie i kontur” określ nowy kolor.

Innym wygodnym sposobem zmiany koloru obiektu jest użycie „Próbnika koloru” [ F7 ]. Używając tego narzędzia kliknij dowolne miejsce na rysunku, a zaznaczony obiekt zostanie wypełniony pobranym w ten sposób kolorem. Użycie skrótu [ Shift+kliknięcie ] spowoduje przypisanie pobranego koloru do konturu.

Powielanie, wyrównywanie, rozmieszczanie

Jedną z najczęściej stosowanych operacji jest powielanie obiektu [ Ctrl+D ]. Duplikat jest umieszczany dokładnie nad oryginałem oraz jest zaznaczony. Można go łatwo odciągnąć za pomocą myszy bądź klawiszy strzałek. W ramach ćwiczenia spróbuj zapełnić poniższy wiersz kopiami tego czarnego kwadratu:

An example image

Prawdopodobnie kopie kwadratu będą rozmieszczone bardziej lub mniej przypadkowo. Aby je rozmieścić równo, pomocne będzie okno dialogowe „Wyrównaj i rozmieść” [ Ctrl+Shift+A ]. Zaznacz wszystkie kwadraty [ Shift+kliknięcie ] bądź wykonaj zaznaczenie elastyczne, otwórz okno dialogowe, naciśnij przycisk „Wyśrodkuj na osi poziomej” i następnie „Rozmieść środki obiektów w równych odstępach poziomo” (przeczytaj podpowiedzi przycisków). Obiekty są teraz ładnie wyrównane i rozłożone równomiernie. Spójrz na kolejne przykłady wyrównania i rozłożenia obiektów:

An example image

Kolejność w stosie (z-order)

Określenie z-order odnosi się do kolejności obiektów w rysunku ułożonych jeden za drugim – w stosie. Określa, który obiekt znajduje się na wierzchu i przesłania inne obiekty. Dwa polecenia znajdujące się w menu „Obiekt” – „Przenieś na wierzch” [ Home ] i „Przenieś na spód” [ End ] przenoszą zaznaczony obiekt na wierzch lub na spód aktywnego stosu – przesłaniają lub są przesłaniane przez cały stos. Dwa inne polecenia – „Przenieś w górę” [ PgUp ] i „Przenieś w dół” [ PgDn ] przenoszą zaznaczony obiekt w górę lub w dół stosu o jeden krok – zaznaczony obiekt zostaje przesunięty – odpowiednio do użytego skrótu – nad lub pod najbliższy mu niezaznaczony obiekt.

W ramach ćwiczenia wypróbuj te polecenia i odwróć kolejność poniższych obiektów, tak aby elipsa po lewej znajdowała się na samej górze stosu, a po prawej na samym dole.

An example image

Bardzo przydatnym skrótem służącym do zaznaczania jest klawisz [ Tab ]. W obiektach ułożonych w stosie (z-order), jeśli żaden obiekt nie został zaznaczony, naciśnięcie klawisza [ Tab ] powoduje zaznaczenie najniżej położonego obiektu. Jeśli obiekt jest zaznaczony, zaznaczenie obiektu położonego powyżej obiektu zaznaczonego. Skrót [ Shift+Tab ] działa odwrotnie – rozpoczyna zaznaczanie od najwyżej położonego obiektu i przechodzi do najniżej położonego. Jeśli tworzone obiekty są dodawane na górę stosu, użycie skrótu [ Shift+Tab ], gdy nic nie jest zaznaczone, spowoduje zaznaczenie ostatnio utworzonego obiektu. Wypróbuj działanie skrótów [ Tab ] i [ Shift+Tab ] na stosie elips znajdującym się powyżej.

Zaznaczanie i przeciąganie obiektów przesłoniętych

Co zrobić, jeśli obiekt, który chcesz zaznaczyć, jest przesłonięty innym obiektem? Można go zobaczyć, jeżeli obiekt powyżej jest częściowo przezroczysty, ale kliknięcie go spowoduje zaznaczenie górnego obiektu, nie tego, którego potrzebujesz.

Służy do tego kombinacja [ Alt+kliknięcie ]. Użycie tej kombinacji po raz pierwszy spowoduje zaznaczenie górnego obiektu, tak jak w przypadku zwykłego kliknięcia. Kolejne użycie [ Alt+kliknięcie ] w tym samym miejscu spowoduje zaznaczenie obiektu przesłoniętego, kolejne – zaznaczenie obiektu znajdującego się jeszcze niżej. Stąd kilkukrotne użycie kombinacji [ Alt+kliknięcie ] z rzędu zaznaczy obiekty od góry do dołu w całym stosie ułożonym wg z-order. Jeżeli zostanie osiągnięty obiekt znajdujący się najniżej, następne [ Alt+kliknięcie ] spowoduje ponowne zaznaczenie obiektu znajdującego się na samym szczycie stosu.

Jeśli twoim systemem operacyjnym jest Linux, może okazać się, że [ Alt+kliknięcie ] nie działa prawidłowo. Ta kombinacja może przesuwać całe okno Inkscape'a. Dzieje się tak, ponieważ menedżer okien zarezerwował [ Alt+kliknięcie ] dla innej czynności. Aby usunąć ten problem, należy odnaleźć konfigurację zachowania okien twojego menedżera okien i wyłączyć działanie tego klawisza albo przypisać działanie klawisza [ Alt ], klawiszowi [ Meta ] lub klawiszowi [ Windows ]. Wówczas Inkscape i inne aplikacje będą mogły swobodnie używać klawisza [ Alt ].

Dobrze, ale co zrobić, jeżeli przesłonięty obiekt jest już zaznaczony? Można użyć klawiszy, by go przekształcić albo przeciągnąć uchwyty zaznaczenia. Jednak przesuwanie samego obiektu ponownie przeniesie zaznaczenie do górnego obiektu. Tak został zaprojektowany mechanizm „kliknij i przeciągnij” – zaznacza górny obiekt znajdujący się pod kursorem, następnie przeciąga zaznaczenie. Aby przeciągać to, co jest teraz zaznaczone bez zaznaczania czegokolwiek innego, użyj kombinacji [ Alt+ciągnięcie ]. Takie działanie spowoduje przesunięcie aktualnego zaznaczenia, bez względu na to, gdzie przeciągasz mysz.

Przećwicz kombinacje [ Alt+kliknięcie ] oraz [ Alt+ciągnięcie ] na tych dwóch brązowych kształtach znajdujących się pod zielonym, przezroczystym prostokątem:

An example image

Podsumowanie

Inkscape posiada dużo więcej funkcji niż te tutaj zaprezentowane, niemniej posługując się wyżej opisanymi technikami można stworzyć prostą, użyteczną grafikę. Aby poznać bardziej zaawansowane techniki, proszę zapoznać się z poradnikami dostępnymi z poziomu menu „Pomoc » Poradniki”.