Deze handleiding demonstreert het basisgebruik van Inkscape. Dit is een gewoon Inkscape document dat je kan bekijken, wijzigen, kopiëren of bewaren.

De Basishandleiding behandelt canvasnavigatie, documentbeheer, het vorm-gereedschap, selectietechnieken, objecttransformatie met het aanwijsgereedschap, groeperen, opmaak, vulling en lijn, uitlijning en volgorde. Voor geavanceerdere onderwerpen, kan je de andere handleidingen in het menu Help raadplegen.

Het canvas verschuiven

Er zijn diverse manieren om het canvas van het document te verschuiven (scrollen). Probeer Ctrl+pijltjestoetsen om te scrollen met het toetsenbord. (Probeer dit nu door naar onder in het document te gaan.) Je kan het canvas ook verslepen met behulp van de middenmuisknop. Een andere mogelijkheid is het gebruik van de schuifbalken (druk op Ctrl+B om ze te tonen of verbergen). Het wiel van je muis werkt ook om verticaal te scrollen; druk op Shift samen met het wiel om horizontaal te scrollen.

In- of uitzoomen

De eenvoudigste manier om te zoomen is door het drukken op de toetsen - en + (of =). Je kan ook Ctrl+middenklik of Ctrl+rechtsklik gebruiken om in te zoomen, Shift+middenklik of Shift+rechtsklik om uit te zoomen, of door het draaien aan het muiswiel in combinatie met Ctrl. Een andere mogelijkheid is het klikken in het zoomveld (onderaan rechts van het documentvenster), het ingeven van een exact percentage zoomen en Enter te drukken. We hebben ook het Zoom-gereedschap (in de knoppenbalk links) dat je laat inzoomen op een regio door er rondom te slepen.

Inkscape bewaart ook de geschiedenis van de zoomniveaus die je gebruikt hebt tijdens de huidige werksessie. Druk op ` om terug te gaan naar de vorige zoom of op Shift+` om naar de volgende te gaan.

Inkscape gereedschappen

De verticale knoppenbalk links toont Inkscape's teken- en bewerkgereedschappen. In het bovenste gedeelte van het venster onder het menu vind je de Opdrachtenbalk met algemene knoppen en de knoppenbalk Gereedschapsdetails met knoppen die specifiek zijn voor elk gereedschap. De statusbalk onderaan het scherm toont bruikbare hints en boodschappen tijdens het werken met Inkscape.

Veel operaties zijn mogelijk aan de hand van sneltoetscombinaties. Open Help > Bedieningsoverzicht voor een volledig overzicht.

Aanmaken en beheren van documenten

Om een leeg document aan te maken, gebruik je Bestand > Nieuw of druk je op Ctrl+N. Om een bestaand SVG-document te openen, gebruik je Bestand > Openen (Ctrl+O). Om te bewaren, gebruik je Bestand > Opslaan (Ctrl+S), of Opslaan als (Shift+Ctrl+S) om te bewaren onder een nieuwe naam. (Inkscape kan soms onstabiel zijn, bewaar dus regelmatig!)

Inkscape gebruikt het SVG-formaat (Scalable Vector Graphics) voor zijn bestanden. SVG is een open standaard die breed ondersteund wordt door grafische software. SVG-bestanden zijn gebaseerd op XML en kunnen bewerkt worden met elke tekst of XML-editor (buiten Inkscape). Behalve SVG, kan Inkscape importeren en exporteren naar diverse andere formaten (EPS, PNG).

Inkscape opent een nieuw documentvenster voor elk document. Je kan navigeren tussen documenten met behulp van je vensterbeheerder (Eng.: window manager) (bv. door Alt+Tab), of je kan de Inkscape sneltoetscombinatie Ctrl+Tab gebruiken die alle open documentvensters overloopt. (Maak nu een nieuw documentvenster aan en wissel tussen dat en dit document om te oefenen.) Opmerking: Inkscape behandelt deze vensters zoals tabbladen in een webbrowser. Dit betekent dat Ctrl+Tab alleen werkt bij documenten van hetzelfde proces. Indien je meerdere vensters vanuit een bestandsbeheerprogramma opent of indien je meer dan één Inkscape proces start van een icoon, zal dit niet werken.

Vormen maken

Tijd voor enkele mooie vormen! Klik op het Rechthoek-gereedschap in de gereedschappenbalk (of druk op F4) en klik-en-sleep, hetzij in een nieuw document of onmiddellijk hier:

An example image

Zoals je kan zien, zijn rechthoeken standaard blauw met een zwarte lijn (rand), en volledig opaak. Hieronder zien we hoe we dat kunnen veranderen. Met andere gereedschappen, kan je ook ellipsen, sterren en spiralen maken:

An example image

Deze gereedschappen zijn bekend onder de gemeenschappelijke noemer vormgereedschappen. Elke vorm die je maakt, toont een of meer diamandvormige handvatten; tracht deze te verslepen en zie hoe de vorm verandert. Het gereedschapspaneel voor een vormgereedschap is een andere weg om een vorm aan te passen; deze panelen beïnvloeden de huidig geselecteerde vormen (bv. deze die handvatten vertonen) en stellen standaardwaarden in die gelden voor nieuw aangemaakte vormen.

Om je laatste actie Ongedaan te maken, druk je op Ctrl+Z. (Of, indien je van gedachten verandert, kan je Opnieuw kiezen om de teruggedraaide actie opnieuw uit te voeren met Shift+Ctrl+Z.)

Verplaatsen, schalen en draaien

Het meest gebruikte Inkscape gereedschap is het selectie-gereedschap. Klik op de bovenste knop (met de pijl) op de knoppenbalk of druk F1 of Spatie. Nu kan je elk object op het canvas selecteren. Klik op de onderstaande rechthoek.

An example image

Je zal acht pijlvormige handvatten zien verschijnen rond het object. Nu kan je:

Klik nu opnieuw op de rechthoek. De handvatten veranderen. Nu kan je:

Tijdens het gebruik van het selectie-gereedschap kan je ook numerieke bewerkingsvelden in de gereedschappenbalk (boven het canvas) gebruiken voor het isntellen van exacte waarden voor coördinaten (X en Y) en groote (B and H) van de selectie.

Transformaties met behulp van het toetsenbord

Een van Inkscape's kenmerken is, in tegenstelling tot andere bewerkingspakketten voor vectorafbeeldingen, de nadruk op toegankelijkheid via het toetsenbord. Er is bijna geen commando of actie die niet mogelijk is via het toetsenbord. Objecttransformaties zijn daarop geen uitzondering.

Je kan het toetsenbord gebruiken voor het verplaatsen (pijltjestoetsen), schalen (toetsen < en >) en roteren (toetsen [ en ]) van objecten. Standaard wordt verplaatst en geschaald met 2 pixels; met Shift, verplaats of schaal je met tien keer deze waarde. Ctrl+> en Ctrl+< schalen in of uit tot respectievelijk 200% of 50% van het origineel. Standaard wordt er geroteerd in stappen van 15 graden; met Ctrl roteer je in stappen van 90 graden.

Echter, misschien zijn pixel-grootte transformaties nog het meest bruikbaar. Deze worden aangeroepen via Alt in combinatie met de transformatietoets. Bijvoorbeeld, Alt+pijltjestoetsen zal de selectie met 1 pixel verplaatsen bij de huidige zoom (bijvoorbeeld met 1 schermpixel, niet te verwarren met de px eenheid die een SVG-lengteëenheid is onafhankelijk van de zoom). Dit betekent dat indien je inzoomt, een Alt+pijltjestoets zal resulteren in een kleinere absolute verplaatsing die er nog steeds uitziet als een één-pixel verplaatsing op je scherm. Het is dus mogelijk om objecten te positioneren met een arbitraire precisie door het eenvoudig in- of uitzoomen.

Op dezelfde wijze zullen Alt+> en Alt+< de selectie schalen zodat de zichtbare grootte met een schermpixel verandert; Alt+[ en Alt+] roteren zodat het punt dat het verste van het rotatiemiddelpunt ligt met één schermpixel verplaatst.

Opmerking: Linux gebruikers krijgen mogelijk niet de verwachte resultaten met de Alt+pijltjestoets en enkele andere toetsenbordcombinaties indien hun vensterbeheerder (VB) deze toetsenbordacties opvangt vooraleer ze Inkscape bereiken. Een mogelijke oplossing hiervoor zou het veranderen van de relevante VB configuratie kunnen zijn.

Meervoudige selecties

Je kan een willekeurig aantal objecten tegelijk selecteren met behulp van Shift+klik. Daarnaast kan je slepen rond de objecten die je moet selecteren; dit wordt elastiekselectie genoemd. (Het selectiegereedschap maakt een elastiek wanneer gesleept wordt over een lege ruimte. Echter, indien je op Shift drukt vooraleer te beginnen met slepen, zal Inkscape altijd een elastiek maken.) Oefen door het selecteren van de drie onderstaande vormen:

An example image

Gebruik nu de elastiek (door slepen of Shift+slepen) om de twee ellipsen te selecteren maar niet de rechthoek:

An example image

Elk individueel object in een selectie vertoont een selectie-aanduiding — standaard gestreept rechthoekig frame. Deze aanduidingen maken het eenvoudig om in een oogopslag te zien wat geselecteerd is en wat niet. Bijvoorbeeld, indien je beide ellipsen en de rechthoek selecteert zou het zonder de selectie-aanduidingen erg moeilijk zijn om te raden of de ellipsen geselecteerd zijn of niet.

Shift+klikken op een geselecteerd object haalt het uit de selectie. Selecteer de drie bovenstaande objecten en gebruik dan Shift+klik om beide ellipsen uit de selectie te halen en zodoende enkel de rechthoek in de selectie over te houden.

Het drukken op Esc deselecteert alle geselecteerde objecten. Ctrl+A selecteert alle objecten in de huidige laag (indien je geen lagen creëerde, is deze dezelfde voor alle objecten in het document).

Groeperen

Verschillende objecten kunnen gecombineerd worden in een groep. Een groep gedraagt zich als een enkel object tijdens het slepen of transformeren. Hieronder zijn de drie objecten links onafhankelijk; dezelfde drie objecten rechts zijn gegroepeerd. Tracht de groep te verslepen.

An example image

Om een groep te creëren, selecteer je de objecten en druk je op Ctrl+G. Om een of meer groepen te degroeperen, selecteer je ze en druk je op Ctrl+U. Groepen kunnen zoals elk ander object zelf gegroepeerd worden: dergelijke recursieve groepen kunnen gaan tot elke mogelijke diepte. Echter, Ctrl+U degroepeert enkel het hoogste groepsniveau in een selectie; je zal herhaaldelijk op Ctrl+U moeten drukken indien je een groep-in-groep volledig wil degroeperen.

Echter, je hoeft niet noodzakelijk te degroeperen indien je een object in een groep wil bewerken. Ctrl+klik daarvoor op het object: alleen dat object wordt geselecteerd en is wijzigbaar. Je kan Shift+Ctrl+klikken op verschillende objecten (in of uit een groep) voor meervoudige selectie ongeacht de eventuele groepering. Tracht de individuele vormen in de groep (boven rechts) te verplaatsen of te transformeren zonder te degroeperen. Deselecteer vervolgens en selecteer de groep zoals normaal zodat je kan zien dat de vormen steeds gegroepeerd blijven.

Vulling en lijn

Veel van Inkscape's functies zijn beschikbaar via dialoogvensters. Wellicht de eenvoudigste wijze om een object te kleuren is het openen van het dialoogvenster Paletten in het menu Beeld (of druk op Shift+Ctrl+W), selecteer een object en klik op een palet om te verven (vulkleur veranderen).

Krachtiger is het dialoogvenster Opvulling en lijnen van het menu Object (of duk op Shift+Ctrl+F). Selecteer de vorm en open het dialoogvenster Opvulling en lijnen.

An example image

Je zal zien dat het dialoogvenster drie tabbladen heeft: Vullen, Lijnkleur en Lijnstijl. Het tabblad Vullen laat je toe om de vulling (binnenzijde) van het/de geselecteerde object(en) te bewerken. Door gebruik te maken van de knoppen in dit tabblad, kan je het type vulling selecteren, inclusief geen vulling (de knop met de X), egale vulkleur, maar ook lineaire en radiale kleurverlopen. Voor de bovenstaande vorm zal de knop Egale kleur geactiveerd zijn.

Verder zie je een aantal kleurselectiesystemen, elk in hun eigen tabblad: RGB, TVL, CMYK en Wiel. Misschien de meest handige is het wiel, waar je kan draaien aan de driehoek om een tint te selecteren en vervolgens een kleurnuance van de tint in de driehoek. Elk kleurselectiesysteem bevat een schuifbalk om de alfa (transparantie) van de geselecteerde objecten in te stellen.

Wanneer je een object selecteert, wordt de kleurselectie geupdated om de huidige vulling en lijn weer te geven (voor meerdere geselecteerde objecten toont het dialoogvenster hun gemiddelde kleur). Oefen met deze voorbeelden of creëer je eigen vormen:

An example image

Met behulp van het tabblad Lijnkleur kan je de lijn (rand) van een object verwijderen, de kleur en transparantie ervan instellen:

An example image

Het laatste tabblad, Lijnstijl, laat je toe om de breedte en andere parameters van de lijn in te stellen:

An example image

Tot slot kan je in plaats van een egale kleur ook gebruik maken van kleurverlopen voor vullingen of lijnen:

An example image

Wanneer je verandert van egale kleur naar kleurverloop gebruikt het nieuw gecreëerde kleurverloop de vorige egale kleur, gaande van opaak naar transparant. Open het gereedschap Kleurverlopen (Ctrl+F1) om de kleurverloophandvatten te verslepen — de punten verbonden door lijnen die de richting en lengte van het kleurverloop bepalen. Wanneer een van de kleurverloophandvatten is geselecteerd (blauw opgelicht), stelt het dialoogvenster Opvulling en lijnen de kleur van dat handvat in, in plaats van de kleur van het volledige geselecteerde object.

Nog een andere handige manier om de kleur van een object te veranderen is door het gebruik van het pipet-gereedschap (F7). Klik daarvoor ergens in de afbeelding met dit gereedschap en de gekozen kleur zal toegepast worden op de vulling van de geselecteerde objecten (Shift+klik zal de lijnkleur toepassen).

Duplicatie, uitlijning en verdeling

Een van de meest voorkomende operaties is het dupliceren van een object (Ctrl+D). Het duplicaat wordt exact boven het origineel geplaatst en is geselecteerd. Zo kan je het wegslepen met de muis of de pijltjestoetsen. Tracht bij wijze van oefening de lijn te vullen met kopieën van dit zwart vierkant:

An example image

Wellicht zijn de kopieën van het vierkant min of meer random geplaatst. In dergelijk gevallen is het dialoogvenster Uilijnen en verdelen (Ctrl+Shift+A) bruikbaar. Selecteer alle rechthoeken (Shift+klik of maak een elastiek), open het dialoogvenster en druk op de knop “Objecten horizontaal centreren”, vervolgens op “De horizontale afstand tussen objecten gelijk maken” (zie de tips bij de knoppen). De objecten zijn nu mooi gealineëerd en equidistant verspreid. Hier zijn enkele andere voorbeelden van uitlijning en verdeling:

An example image

Z-volgorde

De term z-volgorde refereert naar de stapelvorlgorde van objecten in een afbeelding, bijvoorbeeld naar welke objecten bovenaan zijn en het zicht op andere objecten beperken. De twee commando's in het menu Object, Bovenaan (de toets Home) en Onderaan (de toets End), zullen de geselecteerde objecten verplaatsen naar de top of bodem van de huidige laag. Twee andere commando's, Omhoog (PgUp) en Omlaag (PgDn), brengen de selectie slechts een stap naar boven of onder, dit is verplaatsen voorbij een niet geselecteerd object in de z-volgorde (enkel objecten die met de selectie overlappen tellen mee; Indien niets met de selectie overlapt, verplaatsen Omhoog en Omlaag deze naar de top of bodem).

Oefen het gebruik van deze commando's door de z-volgorde van onderstaande objecten om te keren, zodanig dat de meest linkse ellips bovenaan ligt en de meest rechtse onderaan:

An example image

Een erg handige selectie-sneltoets is de Tab-toets. Indien niets geselecteerd is, selecteert het het onderste object. Zoniet selecteert het het object boven de geselecteerde object(en) in z-volgorde. Shift+Tab werkt in omgekeerde volgorde, startend bij het bovenste object en naar beneden gaande. Aangezien de objecten die je aanmaakt, toegevoegd worden aan de top van de stapel zal het drukken op Shift+Tab zonder selectie voor de eenvoud het object selecteren dat je het laatst aanmaakte. Oefen het gebruik van Tab en Shift+Tab met de stapel ellipsen hierboven.

Selecteren onder iets en verslepen selectie

Wat moet je doen indien het object dat je nodig hebt verborgen is achter een ander object? Je kan het onderste object nog zien, indien het bovenste (partieel) transparant is, maar het klikken hierop selecteert het bovenste object, niet datgene dat je nodig hebt.

Daarom is er Alt+klik. De eerste Alt+klik selecteert het bovenste object, net zoals de reguliere klik. Echter, de volgende Alt+klik op hetzelfde punt zal het object onder het bovenste selecteren; daarna het volgende, het object daaronder, etc. Bijgevolg zullen verschillende opeenvolgende Alt+klik's een cyclus vormen van top naar bodem op het klikpunt. Bij het bereiken van het onderste object, zal de volgende Alt+klik automatisch opnieuw het bovenste object selecteren.

[Indien je op Linux werkt, is het mogelijk dat Alt+klik niet correct werkt. In dat geval zal het het volledige Inkscape venster verplaatsen. Dit is zo omdat je vensterbeheerder Alt+klik heeft gereserveerd voor een andere actie. De manier om dit op te lossen is het zoeken van het venstergedrag in de configuratie van de vensterbeheerder, en dit ofwel uitschakelen, of het toekennen aan de Meta toets (aka Windows toets), opdat Inkscape en andere applicaties de Alt-toets vrij kunnen gebruiken.]

Dit is mooi, maar wat kan je doen zodra je een onder-het-oppervlak object geselecteerd hebt? Je kan de toetsen gebruiken om het te transformeren en je kan de selectiehandvatten verslepen. Echter, het slepen van het object zelf, stelt de selectie opnieuw in naar het bovenste object (dit is hoe het klik-en-sleep-gedrag is ontworpen om te werken - het selecteert eerst het (bovenste) object onder de cursor en versleept vervolgens de selectie). Om Inkscape te vertellen dat wat nu geselecteerd is te verslepen, zonder iets anders te selecteren, gebruik je Alt+slepen. Dit zal de huidige selectie verplaatsen onafhankelijk van waar je met je muis sleept.

Oefen Alt+klik en Alt+slepen op de twee bruine vormen onder de groene transparante rechthoek:

An example image

Conclusie

Tot zover de Basishandleiding. Er is veel meer in Inkscape, maar met de hier beschreven technieken kan je reeds eenvoudige, maar bruikbare afbeeldingen maken. Voor complexere dingen kan je de handleiding Geavanceerd of andere handleidingen raadplegen in Help > Handleidingen.