Follow us on:

Home

Inkscape tutorial: Dasar

Tutorial ini menampilkan penggunaan dasar dari Inkscape. Ini adalah dokumen Inskscape reguler yang bisa anda lihat, atur, salin, atau simpan.

Tutorial Dasar ini meliputi navigasi kanvas, mengatur dokumen, dasar shape tool, tehnik seleksi, transformasi obyek dengan selector, grouping, mengatur fill and stroke, alignment, dan z-order. Untuk bahasan lebih dalam, lihat tutorial lain di menu Help.

Menggulung kanvas

Banyak cara untuk menggulung (scroll) kanvas dokumen. Bisa dengan Ctrl+tombol panah pada keyboard. (Cobalah untuk menggulung dokumen ini kebawah.) Anda juga bisa menyeret kanvas ini dengan tombol tengah pada tetikus (mouse). Atau, anda bisa menggunakan scrollbar (tekan Ctrl+B untuk menampilkan atau menyembunyikannya). Roda tengah tetikus anda juga bisa digunakan untuk menggulung secara vertikal; gunakan Shift dengan roda untuk menggulung secara horisontal

Zum kedalam atau keluar

Cara paling mudah untuk zum adalah menekan tombol - dan +. Anda juga bisa menggunakan Ctrl+klik tengah atau Ctrl+klik kanan untuk zum masuk, Shift+klik tengah atau Shift+klik tengah untuk zum keluar, atau memutar roda mouse sambil menekan tombol Ctrl. Atau, anda bisa menggunakan daerah masukan zum pada aplikasi (terletak di bawah kanan jendela dokumen ini), ketikkan nilai zum yang anda inginkan dalam %, kemudian tekan Enter. Kami juga memiliki Zoom tool (pada toolbar sebelah kiri) untuk melakukan zum dengan menyeretnya ke daerah yang ingin dizum.

Inkscape juga menyimpan sejarah level zum yang anda telah gunakan setiap sesi. Tekan tombol ` untuk kembali ke zum sebelumnya, atau Shift+` untuk zum selanjutnya.

Peralatan Inkscape

Toolbar vertikal di sebelah kiri menampilkan peralatan menggambar dan mengedit Inkscape. Pada bagian atas dari jendela, dibawah menu, terdapat Commands bar dengan tombol command biasa, dan Tool Controls bar dengan kontrol spesifik untuk masing-masing peralatan. status bar pada bagian bawah jendela akan menampilkan petunjuk dan pesan yang berguna saat anda bekerja.

Banyak operasi yang bisa dilakukan dengan shortcut keyboard. Bukalah Help > Keys and Mouse untuk melihat referensi lengkapnya.

Membuat dan mengatur dokumen

Untuk membuat dokumen baru yang kosong, gunakan File > New atau tekan Ctrl+N. Untuk membuka dokumen SVG yang sudah ada, gunakan File > Open (Ctrl+O). Untuk menyimpan, gunakan File > Save (Ctrl+S), atau Save As (Shift+Ctrl+S) untuk menyimpannya dengan nama baru. (Inkscape mungkin masih belum stabil, jadi ingatlah untuk sering menyimpan!)

Inkscape menggunakan format SVG (Scalable Vector Graphics) sebagai berkasnya. SVG adalah standar terbuka yang didukung oleh piranti lunak grafis. Berkas SVG didasari oleh XML dan bisa diedit dengan editor teks apa saja ataupun editor XML (yang tentu terpisa dari Inkscape). Selain SVG, Inkscape juga bisa mengimpor dan mengekspor beberapa format lain (EPS, PNG)

Inkscape membuka jendela yang berbeda untuk tiap dokumen. Anda bisa berpindah-pindah antara jendela dengan menggunakan window manager anda (contohnya dengan Alt+Tab) atau bisa juga dengan shortcut Inkscape Ctrl+Tab, yang nantinya akan menampilkan semua jendela dokumen yang terbuka. (Buatlah sebuah dokumen baru dan berpindah-pindahlah antara dokumen baru tersebut dengan dokumen ini untuk latihan.) Pesan: Inkscape memperlakukan jendela-jendela ini seperti tab pada web browser, artinya, Ctrl+Tab hanya bekerja pada dokumen yang prosesnya sama. Jika anda membuka banyak berkas atau menjalankan lebih dari satu proses Inkscape, itu tidak akan bekerja.

Membuat bentuk

Saatnya untuk sedikit bentuk yang indah! Klik pada Rectangle tool di toolbar (atau tekan F4) kemudian klik-dan-seret, entah ke dokumen kosong baru atau disini:

An example image

As you can see, default rectangles come up blue, with a black stroke (outline), and fully opaque. We'll see how to change that below. With other tools, you can also create ellipses, stars, and spirals:

An example image

Peralatan ini dikenal sebagai shape tools. Tiap bentuk (shape) yang anda buat menampilkan satu atau lebih handles berbentuk berlian; cobalah menyeret mereka untuk melihat bagaimana mereka bekerja. Panel Controls untuk shape tool adalah cara lain untuk mengatur bentuk; Panel tersebut mempengaruhi bentuk yang diseleksi (contohnya yang menampilkan handles) and dan mendefinisikan bawaan yang akan digunakan jika bentuk baru dibuat.

Untuk membatalkan perubahan yang terakhir anda lakukan (undo), tekan Ctrl+Z. (Atau jika anda berubah pikiran, anda ingin kembali ke perubahan terakhir, redo, anda bisa menggunakan Shift+Ctrl+Z.)

Memindahkan, mengatur skala, memutar

Peralatan inkscape yang paling sering digunakan adalah Selector. Klik tombol paling atas (yang bertanda panah) pada toolbar, atau tekan F1 atau Space. Kini anda bisa memilih obyek apa saja pada kanvas. Klik persegi dibawah.

An example image

Anda akan melihat empat handles berbentuk panah muncul di sekitar obyek. Kini anda bisa:

Sekarang klik persegi tersebut lagi. Bentuk handlenya berubah. Kini anda bisa:

Saat masih di Selector, anda bisa juga menggunakan masukan nomor yang terdapat pada Controls bar (disebelah atas kanvas) untuk mengatur nilai eksak bagi koordinat (X dan Y) dan ukuran (W dan H) dari seleksi.

Merubah dengan tombol keyboard

Salah satu fitur Inkscape yang jarang ditemui dari editor vektor lainnya adalah aksesibilitas keyboard. Sangat sulit menemukan perintah atau aksi yang tidak bisa dilakukan oleh keyboard. Merubah (transforming) obyek juga termasuk.

Anda bisa menggunakan keyboard untuk memindahkan (tombol arrow/panah), mengubah ukuran (tombol < dan >), dan memutar (tombol [ dan ]) obyek. Pergerakan pindah dan skala bawaan adalah 2px; dengan Shift, anda bergerak 10 kali lipat. Ctrl+> dan Ctrl+< menaikkan atau menurunkan skala sampai 200% atau 50% dari asalnya. Rotasi/putaran bawaan adalah 15 derajat; dengan Ctrl, anda memutarnya 90 derajat.

Tetapi, mungkin yang paling berguna adalah pixel-size transformations, yang dijalankan dengan Alt bersama tombol transform (perubahan). Sebagai contoh, Alt+arrows/panah akan memindahkan seleksi sebesar 1 pixel pada tingkat zum saat itu (atau 1 screen pixel - pixel pada layar, bukan pada program). Ini berarti jika anda melakukan zum masuk, satu kali Alt+arrow/panah akan menghasilkan pergerakan yang tampak kecil/pendek pada layar anda. Ini memungkinkan pemosisian obyek dengan tingkat presisi yang akurat dengan melakukan zum keluar atau kedalam sesuai yang diperlukan.

Sedikit mirip, Alt+> dan Alt+< mengatur ukuran yang diseleksi sehingga ukuran yang nampak akan berubah per 1 screen pixel, dan Alt+[ dan Alt+] memutarnya sehingga titik paling jauh dari titik tengah akan bergerak per 1 screen pixel.

Pesan: Pengguna Linux mungkin tidak bisa mendapatkan hasil yang diharapkan dengan Alt+arrow dan beberapa kombinasi tombol yang lain jika Window Manager mereka menangkap penekanan kombinasi tombol ini sebelum kombinasi tersebut ditangkap aplikasi Inkscape. Salah satu solusinya adalah mengatur ulang konfigurasi Window Manager.

Seleksi lebih dari satu

Anda bisa memilih nomor berapa saja dari obyek secara simultan dengan menggunakan Shift+click. Atau, anda juga bisa menyeret kursor di sekitar obyek-obyek yang ingin anda seleksi; ini disebut rubberband selection. (Selektor menghasilkan rubberband saat diseret ke daerah kosong, jika anda menekan Shift sebelum mulai menyeret, Inkscape akan selalu membuat rubberband.) Berlatihlah dengan menyeleksi tiga bentuk dibawah:

An example image

Sekarang, gunakan rubberband (dengan menyeret atau Shift+drag/seret) untuk memilih dua lingkaran tanpa memilih persegi

An example image

Setiap obyek individual yang dipilih menampilkan selection cue —, sebuah bingkai garis persegi. Cue/tanda ini memudahkan anda untuk melihat apakah obyek terpilih atau tidak. Contohnya, jika anda memilih dua lingkaran dan persegi, tanpa tanda tersebut anda akan sulit menebak apakah lingkaran tersebut terpilih/terseleksi atau tidak.

Menggunakan Shift+klik pada obyek yang dipilih memisahkan dia dari seleksi. Pilih tiga obyek diatas, kemudian gunakan Shift+klik untuk memisahkan lingkaran dari seleksi dan menyisakan hanya persegi.

Menekan tombol Esc memisahkan semua obyek yang sudah dipilih. Ctrl+A memilih semua obyek yang ada pada layer (jika anda tidak membuat layer, berarti semua obyek yang ada pada dokumen).

Grouping

Beberapa obyek bisa digabungkan menjadi satu group/grup. Sebuah group/grup bersifat layaknya sebuah obyek saat anda menyeret atau merubah bentuknya. Dibawah, tiga obyek disebelah kiri berdiri sendiri; obyek yang sama pada layar sebelah kiri sudah digrup. Cobalah menyeret yang segrup.

An example image

Untuk membuat grup, pilihlah satu atau lebih obyek, dan tekan Ctrl+G. Untuk melepas satu atau lebih dari grup, tekan Ctrl+U. Sebuah grup yang sudah jadi masih bisa digrup lagi, seperti obyek yang lain; menghasilkan rantai grup yang sangat panjang. Meskipun begitu, Ctrl+U hanya melepas grup yang terakhir dibuat; Anda harus menekan Ctrl+U berkali-kali jika ingin melepas total sebuah grup yang terdiri dari banyak grup.

Anda tidak perlu melepas grup jika hanya ingin mengedit sebuah obyek dalam grup. Gunakan Ctrl+klik pada objel tersebut, dan obyek tersebut akan terseleksi dan bisa diedit sendiri secara terpisah, atau Shift+Ctrl+klik pada beberapa obyek (diluar atau didalam grup) untuk memilih lebih dari satu seleksi tanpa harus digrup. Cobalah untuk memindahkan atau merubah bentuk masing-masing bentuh yang berada dalam satu grup (kanan atas) tanpa melepas grupnya, kemudian coba jalankan sebagai grup normal untuk melihat apakah obyek-obyek tersebut masih berada dalam satu grup.

Fill dan stroke

Banyak fungsi Inkscape yang tersedia via dialogs. Mungkin yang paling sederhana adalah mengecat sebuah obyek dengan sebuah warna dengan membuka dialog Swatches dari menu View (atau tekan Shift+Ctrl+W), pilihlah sebuah obyek, kemudian klik swatch untuk mengecatnya (mengganti warna yang mengisinya/fill color).

Lainnya adalah dengan dialog Fill and Stroke dari menu Object (atau tekan Shift+Ctrl+F). Pilihlah bentuk dibawah ini dan buka dialog Fill and Stroke.

An example image

Anda akan melihat dialog tersebut memiliki tiga tab: Fill, Stroke paint, dan Stroke style. Tab Fill membuat anda bisa mengedit fill (interior, warna isi) dari obyek yang terpilih. Menggunakan tombol dibawah tab tersebut, anda bisa memilih tipe fill, termasuk diantaranya tanpa fill (tombol dengan tulisan X), bisa dengan satu warna (flat color fill), atau gradiasi linear dan radial. Untuk bentuk diatas, tombol flat fill akan diaktifkan.

Dibawahnya, anda bisa melihat koleksi dari color pickers, masing-masing dengan tabnya sendiri: RGB, CMYK, HSL, dan Wheel. Yang paling mudah mungkin Wheel picker, dimana anda bisa memutar segitiga untuk memilih hue pada wheel/roda/lingkaran, untuk kemudian memilih tingkat bayangan hue tersebut dalam segitiga. Semua color picker memiliki tombol geser untuk mengatur nilai alpha (opasitas) obyek yang dipilih.

Kapanpun anda memilih sebuah objel, color picker langsung diperbaharui untuk menampilkan status Fill and Stroke obyek tersebut (untuk obyek lebih dari satu, dialog akan menampilkan warna average/standar.) Bereksperimenlah dengan sampel ini atau buatlah yang baru:

An example image

Dengan menggunakan tab Stroke paint, anda bisa menghapus stroke (garis luar/pinggir) dari obyek, atau mengatur warna dan transparansinya:

An example image

Tab terakhir, Stroke style, membuat anda bisa mengatur lebar dan parameter lain dari stroke:

An example image

Terakhir, selain satu warna, anda juga bisa menggunakan gradients (gradiasi) untuk fill dan/atau stroke:

An example image

Saat anda berubah dari satu warna menjadi gradiasi, gradiasi yang baru diciptakan akan menggunakan warna sebelumnya, dari jelas menjadi transparan. Beralihlah ke Gradient tool (Ctrl+F1) untuk menyeret gradient handles — kontrol tersebut ditampilkan dengan sebuah garis yang menentukan arah dan panjang gradiasi. Setiap handle gradiasi dipilih (disorot dengan warna biru), dialog Fill and Stroke akan menata warna handle tersebut, bukan seluruh obyek.

Salah satu cara lain untuk mengganti warna obyek adalah menggukana Dropper tool (F7). Hanya dengan mengklik bagian manapun dari gambar dengannya, warna yang dipilih akan diberikan ke Fill dari obyek tersebut (Shift+click untuk warna stroke).

Duplikasi, perataan, distribusi

Salah satu pekerjaan yang sering dilakukan adalah duplicating/duplikasi, menggandakan sebuah obyek (Ctrl+D). Duplikat yang dihasilkan akan muncul tepat diatas obyek asalnya, dan langsung terpilih/terseleksi, jadi anda bisa menyeretnya dengan tetikus atau tombol panah. Sebagai latihan, cobalah mengisi garis ini dengan duplikat dari kotak hitam ini.

An example image

Kemungkinan, duplikat dari kotak tersebut lebih kurang acak. Inilah gunanya dialog Align, perataan (Ctrl+Shift+A). Pilih semua kotak tersebut Shift+click atau seret rubberband), buka dialognya dan pilih tombol “Center on horizontal axis”, kemudian tombol “Make horizontal gaps between objects equal” (baca tooltips tombol). Obyek-obyek tersebut kini akan tertata rapi. Berikut adalah contoh perataan dan distribusi lainnya:

An example image

Z-order

Istilah z-order mengacu pada susunan tumpukan dari obyek pada sebuah gambar, misalnya obyek mana yang diatas dan menutupi lainnya. Dua perintah pada menu Obyek, Raise to Top (tombol Home) dan Lower to Bottom (tombol End), akan memindahkan obyek yang terpilih ke bagian paling atas atau paling bawah dari z-order pada layar yang bersangkutan. Dua perintah lainnya, Raise (PgUp) and Lower (PgDn), akan menenggelamkan atau memunculkan satu langkah saja, misalnya memindahkannya melewati satu obyek yang tidak terpilih dalam z-order (hanya obyek yang overlap yang dihitung; Jika tidak ada overlap pada seleksi, Raise dan Lower akan memindahkannya langsung dari atas atau bawah.

Berlatihlah menggunakan perintah ini dengan membalik z-order obyek dibawah ini, sehingga lingkaran paling bawah menjadi paling atas dan sebaliknya:

An example image

Shortkut seleksi yang sangat berguna adalah tombol Tab. Jika tidak ada yang terseleksi/dipilih, dia akan memilih obyek yang paling dibawah; atau dia akan memilih obyek diatas obyek yang dipilih dalam z-order. Menekan Shift+Tab tanpa ada obyek yang dipilih akan memilih obyek terakhir yang anda buat. Berlatihlah menggunakan Tab dan Shift+Tab pada tumpukan lingkaran diatas.

Memilih yang dibawah dan menyeret yang dipilih

Apa yang harus dilakukan jika obyek yang anda butuhkan tersembunyi dibalik obyek yang lain? Anda mungkin masih bisa melihat obyek dibawah jika diatasnya (sebagian) transparan, tapi jika anda klik, yang dipilih adalah obyek yang diatas, bukan dibawahnya.

Inilah gunanya Alt+klik. Pertama-tama, Alt+klik akan memilih obyek paling atas seperti klik biasa. Tapi, Alt+klik berikutnya pada titik yang sama akan memilih obyek dibawahnya, dan seterusnya. Dengan demikian, beberapa kali Alt+klik dalam satu putaran akan hinggap pada masing-masing obyek, dari atas kebawah, dari sususan z-order. Saat sampai ke obyek paling bawah, Alt+klik berikutnya akan memilih yang paling atas.

[Jika anda menggunakan Linux, anda mungkin menemukan bahwa Alt+klik tidak bekerja sebagaimana mestinya. Mungkin malah memindahkan seluruh jendela inkscape. Ini dikarenakan window manager anda mendefinisikan Alt+klik untuk aksi yang lain. Cara memperbaiki ini adalah menemukan konfigurasi Window Behavior window manager anda, untuk dimatikan, atau menggantinya dengan tombol Meta (alias Tombol windos), sehingga Inkscape dan aplikasi lain bisa menggunakan tombol Alt secara bebas.]

Bagus, tapi begitu anda bisa memilih sebuah obyek dibawah obyek lain, apa yang bisa anda lakukan? Anda bisa merubah bentuknya, dan anda bisa menyeret handle yang dipilih. Meskipun begitu, menyeret obyek itu sendiri akan membuat obyek yang dipilih kembali ke yang diatas (inilah cara klik-dan-geser bekerja - ia memilih obyek (di kasus ini, obyek paling atas) yang berada dibawah kursor, untuk kemudian menyeret seleksinya). Untuk memberi tahu Inkscape untuk menyeret apa yang dipilih sekarang tanpa memilih yang lain, gunakan Alt+drag/seret. Ini akan memindahkan obyek yang dipilih saat itu kemanapun anda menyeret tetikus.

Berlatihlah menggunakan Alt+klik dan Alt+drag/seret pada dua obyek coklat dibawah persegi hijau transparan ini:

An example image

Akhir

Ini mengakhiri tutorial Dasar. Masih banyak yang bisa dilakukan dengan Inkscape, tapi dengan tehnik-tehnik yang diterangkan tadi, anda sudah bisa menghasilkan grafis yang sederhana tetapi berguna. Untuk pembahasan yang lebih kompleks, cobalah Advanced dan tutorial-tutorial lain melalui Help > Tutorials.