Follow us on:

Home

Inkscape tutorial: Τα βασικά

Αυτό το μάθημα δείχνει τα βασικά της χρήσης του Inkscape. Αυτό είναι ένα κανονικό έγγραφο Inkscape που μπορείτε να δείτε, να επεξεργασθείτε, να αντιγράψετε ή να αποθηκεύσετε.

Το βασικό μάθημα καλύπτει περιήγηση καμβά, διαχείριση εγγράφων, βασικά εργαλεία σχημάτων, τεχνικές επιλογής, μετασχηματισμός αντικειμένων με επιλογέα, ομαδοποίηση, ορισμός γεμίσματος και πινελιάς, ευθυγράμμιση και διάταξη-z. Για πιο προχωρημένα θέματα, κοιτάξτε τα άλλα μαθήματα στο μενού βοήθειας.

Μετακίνηση στον καμβά

Υπάρχουν πολλοί τρόποι για μετακίνηση (κύλιση) του καμβά του εγγράφου. Δοκιμάστε τα πλήκτρα Ctrl+βέλος για κύλιση με το πληκτρολόγιο. (Δοκιμάστε το τώρα να κυλίσετε αυτό το έγγραφο προς τα κάτω). Μπορείτε επίσης να σύρετε τον καμβά με το μεσαίο πλήκτρο του ποντικιού. Ή, μπορείτε να χρησιμοποιήσετε τις γραμμές κύλισης (πατήστε Ctrl+B για να εμφανίσετε ή να τις αποκρύψετε). Ο τροχός στο ποντίκι σας επίσης δουλεύει για κατακόρυφη κύλιση. Πατήστε Shift με τον τροχό να για οριζόντια κύλιση.

Μεγέθυνση και σμίκρυνση

Ο πιο εύκολος τρόπος εστίασης είναι πιέζοντας τα πλήκτρα - και +=). Μπορείτε επίσης να χρησιμοποιήσετε Ctrl+μεσαίο κλικ ή Ctrl+δεξί κλικ για μεγέθυνση, Shift+μεσαίο κλικ or Shift+δεξί κλικ για σμίκρυνση, ή περιστροφή του τροχού ποντικιού με Ctrl. Ή, μπορείτε να πατήσετε στο πεδίο εισόδου εστίασης (στην κάτω δεξιά γωνία του παραθύρου εγγράφου), να πληκτρολογήσετε μια τιμή εστίασης σε % και να πατήσετε Enter. Υπάρχει επίσης το εργαλείο εστίασης (στη γραμμή εργαλείων στα αριστερά) που σας επιτρέπει να εστιάσετε σε μια περιοχή σύροντας γύρω της.

Το Inkscape επίσης κρατά ιστορικό των σταθμών εστίασης που χρησιμοποιήσατε στη σύνοδο αυτής της εργασίας. Πατήστε το πλήκτρο ` για να επιστρέψετε στην προηγούμενη εστίαση, ή Shift+` για να προχωρήσετε.

Εργαλεία Inkscape

Η κάθετη γραμμή εργαλείων στα αριστερά εμφανίζει τα σχεδιαστικά και επεξεργαστικά εργαλεία του Inkscape. Στο πάνω μέρος του παραθύρου, κάτω από το μενού, υπάρχει η γραμμή εντολών με κουμπιά γενικών εντολών και η γραμμή ελέγχων εργαλείου με ελέγχους που είναι ειδικοί για κάθε εργαλείο. Η γραμμή κατάστασης στον πυθμένα του παραθύρου εμφανίζει χρήσιμες υποδείξεις και μηνύματα καθώς εργάζεσθε.

Πολλές λειτουργίες είναι διαθέσιμες μέσω συντομεύσεων πληκτρολογίου. Ανοίξτε Βοήθεια > Αναφορά πλήκτρων και ποντικιού για να δείτε την πλήρη αναφορά.

Δημιουργία και διαχείριση εγγράφων

Για να δημιουργήσετε ένα νέο άδειο έγγραφο, χρησιμοποιήστε File > Νέο ή πατήστε Ctrl+N. Για να ανοίξετε ένα υπάρχον έγγραφο SVG, χρησιμοποιήστε Αρχείο > Άνοιγμα (Ctrl+O). Για να αποθηκεύσετε, χρησιμοποιήστε Αρχείο > Αποθήκευση (Ctrl+S) ή Αποθήκευση ως (Shift+Ctrl+S) για να αποθηκεύσετε με νέο όνομα. (Το Inkscape ίσως ακόμα να είναι ασταθές, έτσι να θυμόσαστε να αποθηκεύετε συχνά!)

Το Inkscape χρησιμοποιεί τη μορφή SVG (Scalable Vector Graphics) για τα αρχεία του. SVG είναι ένα ανοικτό πρότυπο πλατιά υποστηριζόμενο από λογισμικό γραφικών. Τα αρχεία SVG βασίζονται σε XML και μπορούν να επεξεργαστούν με οποιοδήποτε επεξεργαστή κειμένου ή XML (πέρα από το Inkscape). Εκτός από SVG, το Inkscape μπορεί να εισάγει και να εξάγει πολλές άλλες μορφές (EPS, PNG).

Το Inkscape ανοίγει ένα ξεχωριστό παράθυρο εγγράφου για κάθε έγγραφο. Μπορείτε να περιηγηθείτε μεταξύ τους χρησιμοποιώντας το διαχειριστή παραθύρου σας (π.χ. με Alt+Tab) ή μπορείτε να χρησιμοποιήσετε τη συντόμευση του Inkscape, Ctrl+Tab, που κάνει κύκλο μεταξύ όλων των ανοικτών παραθύρων εγγράφου. (Δημιουργήστε ένα νέο έγγραφο τώρα και εναλλάξτε μεταξύ του και αυτού του εγγράφου για εξάσκηση.) Σημείωση: Το Inkscape αντιμετωπίζει αυτά τα παράθυρα ως καρτέλες σε περιηγητή ιστού, αυτό σημαίνει ότι η συντόμευση Ctrl+Tab δουλεύει μόνο με έγγραφα που τρέχουν την ίδια διεργασία. Αν ανοίξετε πολλαπλά αρχεία από ένα αρχείο περιηγητή ή εκκινήσετε περισσότερες από μία διεργασίες σε μια εικόνα στο Inkscape δεν θα δουλέψει.

Δημιουργία σχημάτων

Ώρα για μερικά όμορφα σχήματα! Κλικ στο εργαλείο ορθογωνίου στη γραμμή εργαλείων (ή πιέστε F4) και κλικ και σύρσιμο, είτε σε ένα νέο κενό έγγραφο ή ακριβώς εδώ:

An example image

Όπως μπορείτε να δείτε, τα προεπιλεγμένα ορθογώνια γίνονται μπλε, με μια μαύρη πινελιά (περίγραμμα) και πλήρως αδιαφανή. Θα δούμε πώς αλλάζουμε αυτό παρακάτω. Με άλλα εργαλεία, μπορείτε επίσης να δημιουργήσετε ελλείψεις, αστέρια και σπείρες (ελικοειδή):

An example image

Αυτά τα εργαλεία είναι συλλογικά γνωστά ως εργαλεία σχήματος. Κάθε σχήμα που δημιουργείτε εμφανίζει μία ή περισσότερες λαβές σε σχήμα διαμαντιού. Δοκιμάστε να τις σύρετε για να δείτε την ανταπόκριση των σχημάτων. Το φατνίο ελέγχων για το εργαλείο σχήματος είναι ένας άλλος τρόπος για ρύθμιση του σχήματος. Αυτοί οι έλεγχοι επηρεάζουν τα τρέχοντα επιλεγμένα σχήματα (δηλαδή αυτά που εμφανίζουν τις λαβές) και ορίστε το προεπιλεγμένο που θα εφαρμοστεί στα νεοδημιουργούμενα σχήματα.

Για να αναιρέσετε την τελευταία σας πράξη, πατήστε Ctrl+Z. (Ή, εάν αλλάξετε γνώμη ξανά, μπορείτε να επανεκτελέσετε την ενέργεια της ακύρωσης με Shift+Ctrl+Z.)

Μετακίνηση, κλιμάκωση, περιστροφή

Το πιο συχνά χρησιμοποιούμενο εργαλείο του Inkscape είναι ο Επιλογέας. Κλικ στο πιο πάνω κουμπί (με το βέλος) στη γραμμή εργαλείων, ή πατήστε F1 ή διάστημα. Τώρα μπορείτε να επιλέξετε κάθε αντικείμενο στον καμβά. Πατήστε στο πιο κάτω ορθογώνιο.

An example image

Θα δείτε οκτώ λαβές σε σχήμα βέλους να εμφανίζονται γύρω από το αντικείμενο. Τώρα μπορείτε:

Τώρα πατήστε στο ορθογώνιο ξανά. Οι λαβές αλλάζουν. Τώρα μπορείτε:

Ενώ είσαστε στον επιλογέα, μπορείτε επίσης να χρησιμοποιήσετε τα αριθμητικά πεδία εισόδου στη γραμμή ελέγχων (πάνω από τον καμβά) για να ορίσετε ακριβείς τιμές για συντεταγμένες (X και Y) και μεγέθη (πλάτος και ύψος) της επιλογής.

Μετασχηματισμός με πλήκτρα

Ένα από τα χαρακτηριστικά του Inkscape που το ξεχωρίζουν από τους άλλους επεξεργαστές διανυσμάτων είναι η έμφαση του στην προσβασιμότητα του πληκτρολογίου. Δεν υπάρχει πρακτικά καμία εντολή ή ενέργεια που είναι αδύνατο να γίνει από το πληκτρολόγιο και ο μετασχηματισμός αντικειμένων δεν είναι εξαίρεση.

Μπορείτε να χρησιμοποιήσετε το πληκτρολόγιο για να μετακινήσετε (πλήκτρα βελών), να κλιμακώσετε (πλήκτρα < και >) και να περιστρέψετε (πλήκτρα [ και ]) αντικείμενα. Οι προεπιλεγμένες μετακινήσεις και κλιμακώσεις είναι κατά 2 εικονοστοιχεία, με το Shift, μετακινείτε κατά το δεκαπλάσιο του. Ctrl+> και Ctrl+< αυξάνουν ή μειώνουν στο 200% ή 50% του αρχικού, αντίστοιχα. Οι προεπιλεγμένες περιστροφές είναι κατά 15 μοίρες. Με Ctrl περιστρέφετε κατά 90 μοίρες.

Όμως, ίσως το πιο χρήσιμο είναι μετασχηματισμοί μεγέθους εικονοστοιχείου, καλούμενες με τη χρήση Alt με τα πλήκτρα μετασχηματισμού. Π.χ., Alt+βέλη θα μετακινήσουν την επιλογή κατά 1 εικονοστοιχείο στην τρέχουσα εστίαση (δηλαδή κατά 1 εικονοστοιχείο οθόνης, που δεν πρέπει να συγχέεται με τη μονάδα px (εικονοστοιχείο) που είναι μια μονάδα μήκους SVG ανεξάρτητη από την εστίαση). Αυτό σημαίνει ότι εάν μεγεθύνετε, ένα Alt+βέλος θα καταλήξει σε μια μικρότερη απόλυτη κίνηση που θα φαίνεται ακόμα ως ώθηση ενός εικονοστοιχείου στην οθόνη σας. Είναι έτσι δυνατόν να τοποθετήσετε αντικείμενα με ελεύθερη ακρίβεια απλά με μεγέθυνση ή σμίκρυνση όπως χρειάζεται.

Παρόμοια, Alt+> και Alt+< κλιμακώνουν την επιλογή έτσι ώστε οι ορατές αλλαγές μεγέθους της κατά ένα εικονοστοιχείο οθόνης και Alt+[ και Alt+] να την περιστρέφουν έτσι ώστε το πιο απομακρυσμένο από το κέντρο σημείο να μετακινείται κατά ένα εικονοστοιχείο οθόνης.

Σημείωση: Οι χρήστες Linux μπορεί να μην πάρουν τα αναμενόμενα αποτελέσματα με Alt+βέλος και μερικούς άλλους συνδυασμούς πλήκτρων, εάν ο διαχειριστής παραθύρου συλλάβει αυτά τα συμβάντα πλήκτρων πριν φτάσουν στην εφαρμογή inkscape. Μιά λύση θα ήταν η αλλαγή της διαμόρφωσης του διαχειριστή παραθύρου ανάλογα.

Πολλαπλές επιλογές

Μπορείτε να επιλέξετε οποιοδήποτε αριθμό αντικειμένων ταυτόχρονα με Shift+κλικ. Ή, μπορείτε να σύρετε γύρω από τα αντικείμενα που χρειάζεσθε να επιλέξετε. Αυτό λέγεται επιλογή λάστιχο. (Ο επιλογέας δημιουργεί ένα λάστιχο όταν σύρετε από έναν κενό χώρο. Όμως, εάν πατήσετε Shift πριν την έναρξη του συρσίματος, το Inkscape θα δημιουργεί πάντοτε το λάστιχο.) Εξασκηθείτε επιλέγοντας και τα τρία παρακάτω σχήματα:

An example image

Τώρα, χρησιμοποιήστε το λάστιχο (με σύρσιμο ή Shift+σύρσιμο) για να επιλέξετε τις δύο ελλείψεις αλλά όχι το ορθογώνιο:

An example image

Κάθε ατομικό αντικείμενο μέσα σε μια επιλογή εμφανίζει μια υπόδειξη επιλογής — από προεπιλογή, ένα διακεκομμένο ορθογώνιο πλαίσιο. Αυτές οι υποδείξεις κάνουν πιο εύκολο να δει κανείς μονομιάς, τι επιλέχτηκε και τι όχι. Π.χ., εάν επιλέξετε και τις δύο ελλείψεις και το ορθογώνιο, χωρίς τις υποδείξεις θα ήταν δύσκολο να μαντέψετε εάν οι ελλείψεις είναι επιλεγμένες ή όχι.

Shift+κλικ σε ένα επιλεγμένο αντικείμενο το αποκλείει από την επιλογή. Επιλέξτε και τα τρία πιο πάνω αντικείμενα, έπειτα χρησιμοποιήστε Shift+κλικ για να αποκλείσετε και τις δύο ελλείψεις από την επιλογή αφήνοντας μόνο το επιλεγμένο ορθογώνιο.

Πατώντας Esc αποεπιλέγεται οποιοδήποτε επιλεγμένο αντικείμενο. Ctrl+A επιλέγει όλα τα αντικείμενα στην τρέχουσα στρώση (εάν δεν δημιουργήσατε στρώσεις, είναι το ίδιο όπως όλα τα αντικείμενα στο έγγραφο).

Ομαδοποίηση

Πολλά αντικείμενα μπορούν να συνδυαστούν σε μια ομάδα. Μια ομάδα συμπεριφέρεται ως ένα μόνο αντικείμενο, όταν το σύρετε ή το μετακινείτε. Πιο κάτω, τα τρία αντικείμενα στα αριστερά είναι ανεξάρτητα, τα ίδια τρία αντικείμενα στα δεξιά είναι ομαδοποιημένα. Δοκιμάστε να σύρετε την ομάδα.

An example image

Για να δημιουργήσετε μια ομάδα, επιλέγετε ένα ή περισσότερα αντικείμενα και πατάτε Ctrl+G. Για να αποομαδοποιήσετε μία ή περισσότερες ομάδες, επιλέξτε τις και πατήστε Ctrl+U. Οι ίδιες οι ομάδες μπορούν να ομαδοποιηθούν, όπως κάθε άλλο αντικείμενο. Τέτοιες αναδρομικές ομάδες μπορεί να πάνε σε ελεύθερο βάθος. Όμως, Ctrl+U αποομαδοποιεί μόνο την υψηλότερη στάθμη ομαδοποίησης μιας επιλογής. Θα χρειαστεί να πιέσετε το Ctrl+U επανειλημμένα, εάν θέλετε να αποομαδοποιήσετε πλήρως τις ομάδες των ομάδων.

Δεν χρειάζεται να αποομαδοποιήσετε κατ' ανάγκην, όμως, εάν θέλετε να επεξεργαστείτε ένα αντικείμενο μέσα σε μια ομάδα. Απλά Ctrl+κλικ αυτό το αντικείμενο και θα επιλεγεί και θα γίνει επεξεργάσιμο, ή Shift+Ctrl+κλικ για πολλά αντικείμενα (μέσα ή έξω από κάθε ομάδα) για πολλαπλή επιλογή ανεξάρτητα από την ομαδοποίηση. Προσπαθήστε να μετακινήσετε ή να μετασχηματίσετε τα ατομικά σχήματα στην ομάδα (πάνω δεξιά) χωρίς να τα αποομαδοποιήσετε, μετά αποεπιλέξτε και επιλέξτε την ομάδα κανονικά για να δείτε ότι παραμένει ακόμα ομαδοποιημένη.

Γέμισμα και Πινελιά

Πολλές λειτουργίες του Inkscape είναι διαθέσιμες μέσω διαλόγων. Προφανώς ο πιο απλός τρόπος να βάψετε ένα αντικείμενο με κάποιο χρώμα είναι να ανοίξετε το διάλογο χρωματολόγια από το μενού προβολή (ή πατήστε Shift+Ctrl+W), επιλέξτε ένα αντικείμενο και πατήστε ένα χρώμα για να το βάψετε (αλλάξτε το χρώμα γεμίσματος του).

Πιο ισχυρός είναι ο διάλογος γεμίσματος και πινελιάς από το μενού αντικείμενο (ή πατήστε Shift+Ctrl+F). Επιλέξτε το πιο κάτω σχήμα και ανοίξτε το διάλογο γεμίσματος και πινελιάς.

An example image

Θα δείτε ότι ο διάλογος έχει τρεις καρτέλες: γέμισμα, πινελιά και μορφοποίηση πινελιάς. Η καρτέλα γέμισμα σας επιτρέπει να επεξεργαστείτε το γέμισμα (εσωτερικό) των επιλεγμένων αντικειμένων. Χρησιμοποιώντας τα κουμπιά πιο κάτω από την καρτέλα, μπορείτε να επιλέξετε τύπους γεμίσματος, συμπεριλαμβανόμενων χωρίς χρώμα (το κουμπί με το Χ), επίπεδο χρώμα, καθώς και γραμμικές ή ακτινικές διαβαθμίσεις. Για το πιο πάνω σχήμα, το κουμπί επίπεδου χρώματος θα ενεργοποιηθεί.

Πιο κάτω βλέπετε μια επιλογή των επιλογέων χρώματος, καθένας στη δική του καρτέλα: RGB, CMYK, HSL και τροχός. Ίσως ο πιο βολικός είναι ο επιλογέας τροχού, όπου μπορείτε να περιστρέψετε το τρίγωνο για να επιλέξετε χρώμα στον τροχό και έπειτα επιλογή απόχρωσης του χρώματος μες το τρίγωνο. Όλοι οι επιλογείς χρώματος περιέχουν έναν ολισθητή για ορισμό του άλφα (αδιαφάνειας) των επιλεγμένων αντικειμένων.

Όποτε επιλέγετε ένα αντικείμενο, ο επιλογέας χρώματος ενημερώνεται για να εμφανίσει το τρέχον γέμισμα του και την τρέχουσα πινελιά του (για πολλαπλές επιλογές αντικειμένων, ο διάλογος εμφανίζει το μέσο όρο του χρώματος). Παίξτε με αυτά τα δείγματα ή δημιουργήστε τα δικά σας:

An example image

Χρησιμοποιώντας την καρτέλα πινελιάς, μπορείτε να αφαιρέσετε την πινελιά (περίγραμμα) του αντικειμένου, ή να αποδώσετε οποιοδήποτε χρώμα ή διαφάνεια σε αυτό:

An example image

Η τελευταία καρτέλα, μορφοποίηση πινελιάς, σας επιτρέπει να ορίσετε το πλάτος και άλλες παραμέτρους της πινελιάς:

An example image

Τελικά, αντί για επίπεδο χρώμα, μπορείτε να χρησιμοποιήσετε διαβαθμίσεις για γεμίσματα και/ή πινελιές:

An example image

Όταν αλλάζετε από επίπεδο χρώμα σε διαβάθμιση, η νεοδημιουργούμενη διαβάθμιση χρησιμοποιεί το προηγούμενο επίπεδο χρώμα, πηγαίνοντας από αδιαφανές σε διαφανές. Εναλλάξτε στο εργαλείο διαβάθμισης (Ctrl+F1) για να σύρετε τις λαβές διαβάθμισης — τους ελέγχους συνδεμένους με γραμμές που ορίζουν την κατεύθυνση και το μήκος της διαβάθμισης. Όταν οποιαδήποτε από τις λαβές διαβάθμισης επιλέγεται (τονισμένο μπλε), ο διάλογος γεμίσματος και πινελιάς ορίζει το χρώμα αυτής της λαβής αντί για το χρώμα του συνολικού επιλεγμένου αντικειμένου.

Ένας άλλος ακόμα βολικός τρόπος για αλλαγή χρώματος ενός αντικειμένου είναι χρησιμοποιώντας το εργαλείο σταγονόμετρου (F7). Απλά κλικ οπουδήποτε στη περιοχή σχεδίασης με αυτό το εργαλείο και το επιλεγμένο χρώμα θα αποδοθεί στο γέμισμα του επιλεγμένου αντικειμένου (Shift+κλικ θα αποδώσει το χρώμα πινελιάς).

Διπλασιασμός, ευθυγράμμιση, κατανομή

Μια από τις πιο συνηθισμένες λειτουργίες είναι διπλασιασμός ενός αντικειμένου (Ctrl+D). Το αντίγραφο τοποθετείται ακριβώς πάνω από το αρχικό και επιλέγεται, έτσι μπορείτε να το σύρετε μακριά με το ποντίκι ή με τα πλήκτρα βελών. Για εξάσκηση, δοκιμάστε το γέμισμα της γραμμής με αντίγραφα αυτού του μαύρου τετραγώνου:

An example image

Υπάρχουν πιθανότητες, τα αντίγραφά σας του τετραγώνου να είναι τοποθετημένα περισσότερο ή λιγότερο τυχαία. Εδώ είναι που ο διάλογος ευθυγράμμιση (Ctrl+Shift+A) είναι χρήσιμος. Επιλέξτε όλα τα τετράγωνα (Shift+κλικ ή σύρτε το λάστιχο), ανοίξτε το διάλογο και πατήστε το κουμπί "κεντράρισμα στον οριζόντιο άξονα", έπειτα το κουμπί "εξίσωση οριζόντιων κενών μεταξύ αντικειμένων" (διαβάστε τις συμβουλές του κουμπιού). Τα αντικείμενα είναι τώρα καθαρά ευθυγραμμισμένα και κατανεμημένα σε ίσες αποστάσεις. Να μερικά άλλα παραδείγματα ευθυγράμμισης και κατανομής:

An example image

Διάταξη-Ζ

Ό όρος διάταξη-z αναφέρεται σε μια διάταξη στοίβας αντικειμένων σε ένα σχέδιο, δηλαδή σε ποιο αντικείμενο είναι στην κορυφή και επισκιάζει τα άλλα. Οι δύο εντολές στο μενού αντικειμένου, ανύψωση στην κορυφή (το πλήκτρο Home) και βύθιση στον πυθμένα (το πλήκτρο End), θα μετακινήσουν τα επιλεγμένα αντικείμενά σας στην πιο υψηλή ή στην πιο χαμηλή από τις διατάξεις-z της τρέχουσας στρώσης. Δύο περισσότερες εντολές, ανύψωση (PgUp) και βύθιση (PgDn), θα ανυψώσουν ή θα βυθίσουν την επιλογή μόνο ένα βήμα, δηλαδή θα μετακινήσουν το προηγούμενο μη επιλεγμένο αντικείμενο στη διάταξη-z (μόνο αντικείμενα που επικαλύπτουν την επιλογή μετράνε, εάν τίποτα δεν επικαλύπτει την επιλογή, η ανύψωση και η βύθιση την μετακινούν όλο το δρόμο στην κορυφή ή στον πυθμένα αντίστοιχα).

Εξασκηθείτε χρησιμοποιώντας αυτές τις εντολές αντιστρέφοντας τη διάταξη-z των πιο κάτω αντικειμένων, έτσι ώστε η πιο αριστερή έλλειψη να είναι στην κορυφή και η πιο δεξιά έλλειψη να είναι στον πυθμένα:

An example image

Μια πολύ χρήσιμη συντόμευση επιλογής είναι το πλήκτρο Tab. Εάν τίποτα δεν έχει επιλεγεί, επιλέγει το πιο χαμηλό αντικείμενο. Διαφορετικά επιλέγει το αντικείμενο πάνω από τα επιλεγμένα αντικείμενα στη διάταξη-z. Shift+Tab δουλεύουν αντίστροφα, ξεκινώντας από το πιο ψηλό αντικείμενο και προχωρώντας προς τα κάτω. Αφού τα αντικείμενα που δημιουργείτε προστίθενται στην κορυφή της στοίβας, πατώντας Shift+Tab χωρίς επιλογή θα επιλέξει βολικά το αντικείμενο που δημιουργήσατε τελευταίο. Εξασκηθείτε με τα πλήκτρα Tab και Shift+Tab στη στοίβα των πιο πάνω ελλείψεων.

Επιλογή του από κάτω και σύρσιμο του επιλεγμένου

Τι να κάνετε εάν το αντικείμενο που χρειάζεσθε είναι κρυμμένο πίσω από ένα άλλο αντικείμενο; Ίσως βλέπετε ακόμα το κάτω αντικείμενο εάν το κορυφαίο είναι (μερικώς) διαφανές, αλλά πατώντας το θα επιλέξει το πάνω αντικείμενο, όχι αυτό που χρειάζεσθε.

Για αυτό είναι το Alt+κλικ. Πρώτα Alt+κλικ επιλέγει το κορυφαίο αντικείμενο όπως ένα κανονικό κλικ. Όμως, το επόμενο Alt+κλικ στο ίδιο σημείο θα επιλέξει το αντικείμενο κάτω από το κορυφαίο. Το επόμενο πάτημα το αντικείμενο ακόμα πιο χαμηλά, κλ. Έτσι πολλά Alt+click στη σειρά θα κάνουν κύκλο, κορυφή προς πυθμένα, μέσα από τη συνολική στοίβα των αντικειμένων της διάταξης-z στο σημείο κλικ. Όταν φτάνετε στο κατώτερο αντικείμενο, το επόμενο Alt+κλικ θα επιλέξει ξανά το κορυφαίο αντικείμενο.

[Εάν είσθε στο Linux, ίσως βρείτε ότι Alt+κλικ δεν λειτουργεί κατάλληλα. Αντίθετα, μπορεί να μετακινεί το συνολικό παράθυρο Inkscape. Αυτό συμβαίνει επειδή ο διαχειριστής παραθύρου έχει κρατήσει το +κλικ για διαφορετική ενέργεια. Ο τρόπος να το διορθώσετε είναι να βρείτε τη διαμόρφωση συμπεριφοράς του παραθύρου για τον διαχειριστή παραθύρου σας και είτε να το απενεργοποιήσετε, ή να το αντιστοιχίσετε στο πλήκτρο Meta (πλήκτρο aka Windows - συνήθως δίπλα στο Alt), έτσι ώστε άλλες εφαρμογές να μπορούν να χρησιμοποιήσουν το πλήκτρο Alt ελεύθερα.]

Αυτό είναι ωραίο, αλλά αφού επιλέξετε το αντικείμενο κάτω από την επιφάνεια, τι μπορείτε να κάνετε με αυτό; Μπορείτε να χρησιμοποιήσετε πλήκτρα για να το μετασχηματίσετε και μπορείτε να σύρετε τις λαβές επιλογής. Όμως, σύροντας το αντικείμενο το ίδιο θα επαναφέρει την επιλογή στο κορυφαίο αντικείμενο ξανά (έτσι σχεδιάστηκε να δουλεύει το κλικ και σύρσιμο — επιλέγει το κορυφαίο αντικείμενο κάτω από το δρομέα πρώτο, έπειτα σύρει την επιλογή). Για να πείτε στο Inkscape να σύρετε την τρέχουσα επιλογή χωρίς να επιλέξει τίποτα άλλο, χρησιμοποιήστε Alt+σύρσιμο. Αυτό θα μετακινήσει την τρέχουσα επιλογή άσχετα με το πού σύρετε το ποντίκι σας.

Εξασκηθείτε Alt+κλικ και Alt+σύρσιμο στα δύο καφέ σχήματα κάτω από το πράσινο διαφανές ορθογώνιο:

An example image

Συμπέρασμα

Αυτό κλείνει το βασικό μάθημα. Υπάρχουν πολύ περισσότερα από αυτό στο Inkscape, αλλά με τις τεχνικές που περιγράφτηκαν εδώ, θα μπορείτε ήδη να δημιουργήσετε απλά αλλά χρήσιμα γραφικά. Για πιο περίπλοκο υλικό, συνεχίστε με το προχωρημένο και τα άλλα μαθήματα στο Βοήθεια > Μαθήματα.